summaryrefslogtreecommitdiff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 16:20:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-07 16:20:38 +0300
commit6757ee9d2bbdc3d064eacfc332d756105521166c (patch)
treede6df053ab495410a87c3d08b90f06feaaf4dbd5 /gnu/packages/kerberos.scm
parente3e33b5251e11beb0c77cc39f335a5116ab36f9c (diff)
downloadguix-patches-6757ee9d2bbdc3d064eacfc332d756105521166c.tar
guix-patches-6757ee9d2bbdc3d064eacfc332d756105521166c.tar.gz
gnu: shishi: Use G-expressions.
* gnu/packages/kerberos.scm (shishi)[arguments]: Convert to list of G-Expressions.
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index 8f2bbd1c13..9454a5983e 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -132,17 +132,18 @@ cryptography.")
"14kyj7rdki2g1sj5k42y9v5ya9jar81yw483ivwa80fx2byqyycm"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags
- '("--disable-static"
- "--with-key-dir=/etc/shishi"
- "--with-db-dir=/var/shishi")
+ (list
+ #:configure-flags
+ #~(list "--disable-static"
+ "--with-key-dir=/etc/shishi"
+ "--with-db-dir=/var/shishi")
#:phases
- (modify-phases %standard-phases
- (add-after 'configure 'disable-automatic-key-generation
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "Makefile"
- (("^install-data-hook:")
- "install-data-hook:\nx:\n")))))))
+ #~(modify-phases %standard-phases
+ (add-after 'configure 'disable-automatic-key-generation
+ (lambda _
+ (substitute* "Makefile"
+ (("^install-data-hook:")
+ "install-data-hook:\nx:\n")))))))
(native-inputs (list pkg-config))
(inputs
(list gnutls