summaryrefslogtreecommitdiff
path: root/gnu/packages/kerberos.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 16:13:36 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-07 16:16:42 +0300
commit544ff0b6c2b189b61ae2fa252e6e5233420d06a5 (patch)
treeab1f6235bb6137b50b47530622a8e50c9dad725f /gnu/packages/kerberos.scm
parent120d8f8563106e16375bf092f0fad45f9f2dc697 (diff)
downloadguix-patches-544ff0b6c2b189b61ae2fa252e6e5233420d06a5.tar
guix-patches-544ff0b6c2b189b61ae2fa252e6e5233420d06a5.tar.gz
gnu: shishi: Update to 1.0.3.
* gnu/packages/kerberos.scm (shishi): Update to 1.0.3. [source]: Remove patch. [arguments]: Remove configure flag overriding libgcrypt detection. * gnu/packages/patches/shishi-fix-libgcrypt-detection.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/kerberos.scm')
-rw-r--r--gnu/packages/kerberos.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/kerberos.scm b/gnu/packages/kerberos.scm
index dec09ca791..a52d4b42cc 100644
--- a/gnu/packages/kerberos.scm
+++ b/gnu/packages/kerberos.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -121,32 +121,28 @@ cryptography.")
(define-public shishi
(package
(name "shishi")
- (version "1.0.2")
+ (version "1.0.3")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnu/shishi/shishi-"
version ".tar.gz"))
- (patches (search-patches "shishi-fix-libgcrypt-detection.patch"))
(sha256
(base32
- "032qf72cpjdfffq1yq54gz3ahgqf2ijca4vl31sfabmjzq9q370d"))))
+ "14kyj7rdki2g1sj5k42y9v5ya9jar81yw483ivwa80fx2byqyycm"))))
(build-system gnu-build-system)
(arguments
- '(;; This is required since we patch some of the build scripts.
- ;; Remove first two items for the next Shishi release after 1.0.2 or
- ;; when removing 'shishi-fix-libgcrypt-detection.patch'.
- #:configure-flags
- '("ac_cv_libgcrypt=yes" "--disable-static"
- "--with-key-dir=/etc/shishi" "--with-db-dir=/var/shishi")
+ '(#:configure-flags
+ '("--disable-static"
+ "--with-key-dir=/etc/shishi"
+ "--with-db-dir=/var/shishi")
#:phases
(modify-phases %standard-phases
(add-after 'configure 'disable-automatic-key-generation
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "Makefile"
(("^install-data-hook:")
- "install-data-hook:\nx:\n"))
- #t)))))
+ "install-data-hook:\nx:\n")))))))
(native-inputs (list pkg-config))
(inputs
(list gnutls