summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorThomas Danckaert <post@thomasdanckaert.be>2016-12-01 12:50:16 +0100
committerLudovic Courtès <ludo@gnu.org>2016-12-03 18:55:01 +0100
commitf447dbc79660c6a50c2d8f1a5f47fce966d9baf8 (patch)
tree98921dbe08b8d400985cb58b56858dd91a2de7fe /gnu/packages/kde.scm
parent5bdec7d634ce0058801cd212e9e4ea56e914ca0c (diff)
downloadguix-patches-f447dbc79660c6a50c2d8f1a5f47fce966d9baf8.tar
guix-patches-f447dbc79660c6a50c2d8f1a5f47fce966d9baf8.tar.gz
gnu: Add libksysguard.
* gnu/packages/kde.scm (libksysguard): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm56
1 files changed, 56 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 82e7ed2cc7..9099c5f84a 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -23,6 +23,8 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages documentation)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
@@ -85,6 +87,60 @@ used in KDE development tools Kompare and KDevelop.")
;; source archive
(license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
+(define-public libksysguard
+ (package
+ (name "libksysguard")
+ (version "5.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde//stable/plasma/" version
+ "/libksysguard-" version ".tar.xz"))
+ (sha256
+ (base32
+ "158n30wbpsgbw3axhhsc58hnwhwdd02j3zc9hhcybmnbkfl5c96l"))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kconfigwidgets" ,kconfigwidgets)
+ ("kiconthemes" ,kiconthemes)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdoctools" ,kdoctools)
+ ("kinit" ,kinit)
+ ("knewstuff" ,knewstuff)
+ ("knotifications" ,knotifications)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kio" ,kio)
+ ("ki18n" ,ki18n)
+ ("kservice" ,kservice)
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtwebkit" ,qtwebkit)
+ ("qtx11extras" ,qtx11extras)
+ ("plasma" ,plasma-framework)
+ ("zlib" ,zlib)))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ `(,(string-append "-DKDE_INSTALL_DATADIR="
+ (assoc-ref %outputs "out") "/share"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-cmakelists
+ (lambda _
+ (substitute* "processcore/CMakeLists.txt"
+ (("KAUTH_HELPER_INSTALL_DIR") "KDE_INSTALL_LIBEXECDIR"))))
+ (replace 'check
+ (lambda _ ;other tests require a display and therefore fail
+ (zero? (system* "ctest" "-R" "chronotest")))))))
+ (home-page "https://www.kde.org/info/plasma-5.8.2.php")
+ (synopsis "Network enabled task and system monitoring")
+ (description "KSysGuard can obtain information on system load and
+manage running processes. It obtains this information by interacting
+with a ksysguardd daemon, which may also run on a remote system.")
+ (license license:gpl3+)))
+
(define-public qca
(package
(name "qca")