summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-30 22:43:23 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-01 20:24:47 +0100
commite185e900e59c32dfdf773b4782950700ab7db709 (patch)
treeda40b5c7e774a0863b0772b3a20b65d1c0adc484 /gnu/packages/kde.scm
parent7d796d8068e25595905e30e3e220feb79946d25e (diff)
downloadguix-patches-e185e900e59c32dfdf773b4782950700ab7db709.tar
guix-patches-e185e900e59c32dfdf773b4782950700ab7db709.tar.gz
gnu: kdeconnect: Use qt-build-system.
* gnu/packages/display-managers.scm (kdeconnect): Use qt-build-sytem. [arguments]<modules, imported-modules>: Remove. <phases>: Base on phases from qt-build-system. {wrap-executable}: Remove.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm18
1 files changed, 3 insertions, 15 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 483eeeb2bc..014bca0738 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -24,6 +24,7 @@
(define-module (gnu packages kde)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system qt)
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix licenses) #:prefix license:)
@@ -541,28 +542,15 @@ different notification systems.")
(sha256
(base32
"02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON")
#:tests? #f ; tests fail hard in our build environment
- #:modules ((guix build cmake-build-system)
- (guix build qt-utils)
- (guix build utils))
- #:imported-modules (,@%cmake-build-system-modules
- (guix build qt-utils))
#:phases
- (modify-phases %standard-phases
+ (modify-phases (@ (guix build qt-build-system) %standard-phases)
(add-before 'check 'check-setup
(lambda _
(setenv "QT_QPA_PLATFORM" "offscreen")
- #t))
- (add-after 'install 'wrap-executable
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-qt-program out "../lib/libexec/kdeconnectd")
- (wrap-qt-program out "kdeconnect-cli")
- (wrap-qt-program out "kdeconnect-handler")
- (wrap-qt-program out "kdeconnect-indicator"))
#t)))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)