summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorPrafulla Giri <pratheblackdiamond@gmail.com>2020-09-17 00:55:58 +0545
committerMathieu Othacehe <othacehe@gnu.org>2020-09-18 11:53:38 +0200
commitcd6ec6706c4da76866b83d830ed686b9d036641c (patch)
treef6ff6fff206c7eeb08f0c4c813f63b9e4a3e84b7 /gnu/packages/kde.scm
parent34b6dd36bb63e75a2e64a2c9b008c098162b7558 (diff)
downloadguix-patches-cd6ec6706c4da76866b83d830ed686b9d036641c.tar
guix-patches-cd6ec6706c4da76866b83d830ed686b9d036641c.tar.gz
gnu: kdenlive: Simplify 'wrap-executable phase.
* gnu/packages/kde.scm (kdenlive)[arguments]: Use getenv to set the values of QT_PLUGIN_PATH and QML2_IMPORT_PATH in the wrapper during the 'wrap-executable phase. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index d661b7445b..add33b77fe 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -191,32 +191,23 @@ This package contains GUI widgets for baloo.")
(add-after 'install 'wrap-executable
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
- (qtquickcontrols2 (assoc-ref inputs "qtquickcontrols2"))
(qtbase (assoc-ref inputs "qtbase"))
- (qtdeclarative (assoc-ref inputs "qtdeclarative"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
(ffmpeg (assoc-ref inputs "ffmpeg"))
- (breeze (assoc-ref inputs "breeze"))
- (qml "/lib/qt5/qml"))
+ (breeze (assoc-ref inputs "breeze")))
(wrap-program (string-append out "/bin/kdenlive")
`("PATH" ":" prefix
,(list (string-append ffmpeg "/bin")))
`("XDG_DATA_DIRS" ":" prefix
,(list (string-append breeze "/share")))
`("QT_PLUGIN_PATH" ":" prefix
- ,(map (lambda (label)
- (string-append (assoc-ref inputs label)
- "/lib/qt5/plugins/"))
- '("qtbase" "qtsvg")))
+ ,(list (getenv "QT_PLUGIN_PATH")))
`("FREI0R_PATH" ":" =
(,(string-append frei0r "/lib/frei0r-1/")))
`("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
(,(string-append qtbase "/lib/qt5/plugins/platforms")))
`("QML2_IMPORT_PATH" ":" prefix
- (,(string-append qtquickcontrols qml)
- ,(string-append qtquickcontrols2 qml)
- ,(string-append qtdeclarative qml)))
+ ,(list (getenv "QML2_IMPORT_PATH")))
`("MLT_PREFIX" ":" =
(,(assoc-ref inputs "mlt")))))
#t)))))