summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-06 09:59:41 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 18:24:55 +0100
commit9b98d288c41cf9b3f305ca11f1961eab0b1605bf (patch)
tree4166699f42d3dcea9d90ee63bd8423d0fc0d1bd0 /gnu/packages/kde.scm
parentb2fdd0cf4ade20b3d9bf0b249b32e06e9f8bf1b0 (diff)
downloadguix-patches-9b98d288c41cf9b3f305ca11f1961eab0b1605bf.tar
guix-patches-9b98d288c41cf9b3f305ca11f1961eab0b1605bf.tar.gz
gnu: Add zeroconf-ioslave.
* gnu/packages/kde.scm (zeroconf-ioslave): New variable.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 31b917d033..44f8df387f 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -687,3 +687,31 @@ Python, PHP, and Perl.")
(synopsis "Runtime library for kdegames")
(description "Runtime library for kdegames")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public zeroconf-ioslave
+ (package
+ (name "zeroconf-ioslave")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/zeroconf-ioslave-" version ".tar.xz"))
+ (sha256
+ (base32 "1vbi4kpyrk530q2dj8ql2i0gxjybdbmkqpl8vkhrihl7r7f0xc5p"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kdbusaddons" ,kdbusaddons)
+ ("kdnssd" ,kdnssd)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
+ (synopsis "DNS-SD Service Discovery Monitor")
+ (description "Adds an entry to Dolphin's Network page to show local
+services such as printers which advertise themselves with DNSSD (called Avahi
+or Bonjour by other projects).")
+ (license ;; GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))