summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-06 21:01:09 +0200
committerMarius Bakke <marius@gnu.org>2020-06-06 22:13:26 +0200
commit9141cec489676c4d2dd919bebdc10dd44136adde (patch)
treea11cba5d4c71a2f1358079d39feb9f92891e583d /gnu/packages/kde.scm
parenta5d465e25b43b52dcb94a4facac351cbe9b80f01 (diff)
downloadguix-patches-9141cec489676c4d2dd919bebdc10dd44136adde.tar
guix-patches-9141cec489676c4d2dd919bebdc10dd44136adde.tar.gz
gnu: kdeconnect: Update to 1.4.
* gnu/packages/kde.scm (kdeconnect): Update to 1.4. [arguments]: Add #:phases. [inputs]: Add KIRIGAMI, KPEOPLE, KPEOPLEVCARD, PULSEAUDIO-QT, and QTMULTIMEDIA.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm22
1 files changed, 20 insertions, 2 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 5cf614d9c9..fb14a64988 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -49,6 +50,7 @@
#:use-module (gnu packages graphics)
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-pim)
#:use-module (gnu packages kde-plasma)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -565,7 +567,7 @@ different notification systems.")
(define-public kdeconnect
(package
(name "kdeconnect")
- (version "1.3.5")
+ (version "1.4")
(source
(origin
(method url-fetch)
@@ -574,11 +576,22 @@ different notification systems.")
version ".tar.xz"))
(sha256
(base32
- "02lr3xx5s2mgddac4n3lkgr7ppf1z5m6ajs90rjix0vs8a271kp5"))))
+ "06i6spspqpl79x6z2bfvbgd08b3h1pyx5j1xjhd8ifyrm52pkvna"))))
(build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON"
"-DLIBEXEC_INSTALL_DIR=libexec")
+ #:phases (modify-phases %standard-phases
+ (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; FIXME: <kcmutils_version.h> is not found during one
+ ;; of the compilation steps without this hack.
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-append (assoc-ref inputs "kcmutils")
+ "/include/KF5:"
+ (or (getenv "CPLUS_INCLUDE_PATH")
+ "")))
+ #t)))
#:tests? #f)) ; tests fail hard in our build environment
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -593,12 +606,17 @@ different notification systems.")
("ki18n" ,ki18n)
("kiconthemes" ,kiconthemes)
("kio" ,kio)
+ ("kirigami" ,kirigami)
("knotifications" ,knotifications)
+ ("kpeople" ,kpeople)
+ ("kpeoplevcard" ,kpeoplevcard)
("kwayland" ,kwayland)
("libfakekey" ,libfakekey)
+ ("pulseaudio-qt" ,pulseaudio-qt)
("qca" ,qca)
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
+ ("qtmultimedia" ,qtmultimedia)
("qtx11extras" ,qtx11extras)))
(home-page "https://community.kde.org/KDEConnect")
(synopsis "Enable your devices to communicate with each other")