summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-24 22:28:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-01 11:09:32 +0200
commit550791b8f13a8c18c3f9f9dca527cf69762eeb46 (patch)
tree007fc66ef867840d5ea1667df1312d724adddeea /gnu/packages/kde.scm
parentd34c594aeb01ea5de69909c97d1838da144d839b (diff)
downloadguix-patches-550791b8f13a8c18c3f9f9dca527cf69762eeb46.tar
guix-patches-550791b8f13a8c18c3f9f9dca527cf69762eeb46.tar.gz
gnu: Add snorenotify.
* gnu/packages/kde.scm (snorenotify): New variable.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 64771fcd3b..b74a6051ea 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -22,6 +22,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
+ #:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt))
@@ -51,3 +52,28 @@ straightforward and cross-platform API for a range of cryptographic features,
including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
cards.")
(license license:lgpl2.1)))
+
+(define-public snorenotify
+ (package
+ (name "snorenotify")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://download.kde.org/stable/snorenotify/"
+ version "/src/snorenotify-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; both tests fail, require display
+ (inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qt" ,qt)))
+ (home-page "https://techbase.kde.org/Projects/Snorenotify")
+ (synopsis "Qt notification framework")
+ (description "Snorenotify is a multi platform Qt notification framework.
+Using a plugin system it is possible to create notifications with many
+different notification systems.")
+ (license license:lgpl3)))