summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-02-03 15:45:44 +0100
commit52665d2b6bd709ba46c1e364a6d6164f5f4824ff (patch)
tree55fd79b3939c08f6f6e9fe383f0df5e4caa82b57 /gnu/packages/kde.scm
parent584d08c5c98cb1893e4f44bd1c4191f405b13f01 (diff)
parent0a83339bb1429332ee889e9a976aa214ae2ac0db (diff)
downloadguix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar
guix-patches-52665d2b6bd709ba46c1e364a6d6164f5f4824ff.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm58
1 files changed, 35 insertions, 23 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index 924ca752d9..7a689c9b29 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -67,6 +67,39 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public baloo-widgets
+ (package
+ (name "baloo-widgets")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/baloo-widgets-" version ".tar.xz"))
+ (sha256
+ (base32 "0bba8dgxd7rcjji809kwnw78hl1nb5ssh2ir4k4b0wvx395jifgd"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("baloo" ,baloo)
+ ("kconfig" ,kconfig)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
+ (home-page "https://community.kde.org/Baloo")
+ (synopsis "Wigets for use with Baloo")
+ (description "Baloo is a framework for searching and managing metadata.
+This package contains GUI widgets for baloo.")
+ (license license:lgpl2.0+)))
+
(define-public grantleetheme
(package
(name "grantleetheme")
@@ -89,13 +122,6 @@
("kiconthemes" ,kiconthemes)
("knewstuff" ,knewstuff)
("qtbase" ,qtbase)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://cgit.kde.org/grantleetheme.git")
(synopsis "Library providing Grantlee theme support")
(description "This library provides Grantlee theme support.")
@@ -521,13 +547,7 @@ different notification systems.")
(build-system qt-build-system)
(arguments
`(#:configure-flags '("-DBUILD_TESTING=ON")
- #:tests? #f ; tests fail hard in our build environment
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
+ #:tests? #f)) ; tests fail hard in our build environment
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("kdoctools" ,kdoctools)
@@ -644,7 +664,7 @@ Python, PHP, and Perl.")
"/src/libkdegames-" version ".tar.xz"))
(sha256
(base32 "12dvkmjgbi8dp9y55zmx1pw3zr2i374c4vn3mfn9r31bf06dr701"))))
- (build-system cmake-build-system)
+ (build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
(inputs
@@ -674,14 +694,6 @@ Python, PHP, and Perl.")
("qtbase" ,qtbase)
("qtdeclarative" ,qtdeclarative)
("qtsvg" ,qtsvg)))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'check-setup
- (lambda _
- ;; make Qt render "offscreen", required for tests
- (setenv "QT_QPA_PLATFORM" "offscreen")
- #t)))))
(home-page "https://games.kde.org/")
(synopsis "Runtime library for kdegames")
(description "Runtime library for kdegames")