summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-27 13:21:52 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-11-27 14:27:23 +0100
commit4fbc19e2c004430af36e1595398ae958f62f1e24 (patch)
tree5e06585fc5634ae6253ffdd41b76d4c4c32b0b37 /gnu/packages/kde.scm
parente2f01318af008b7d0a2a02b914ab7e2e80bbce0b (diff)
downloadguix-patches-4fbc19e2c004430af36e1595398ae958f62f1e24.tar
guix-patches-4fbc19e2c004430af36e1595398ae958f62f1e24.tar.gz
gnu: marble-qt: Update to 21.08.3.
* gnu/packages/kde.scm (marble-qt): Update to 21.08.3. [build-system]: Use qt-build-system. [arguments]<#:configure-flags>: Pass "-DBUILD_MARBLE_TESTS=FALSE". [license]: Change to lgpl2.1+. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm68
1 files changed, 33 insertions, 35 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index fa220c91f0..886d8f6025 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -988,44 +988,42 @@ Python, PHP, and Perl.")
(license (list license:gpl2+ license:fdl1.2+))))
(define-public marble-qt
- (let ((release "17.08")
- (commit "fc7166eeef784732033c999ba605364f9c82d21c")
- (revision "1"))
- (package
- (name "marble-qt")
- (version (git-version release revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://invent.kde.org/education/marble.git/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0m0sf3sddaib7vc5lhbmh7ziw07p1hahg02f65sgfylyl5f5kj92"))
- (patches (search-patches
- "marble-qt-add-qt-headers.patch"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f ; libmarblewidget-qt5.so.28 not found
- #:configure-flags
- '("-DCMAKE_BUILD_TYPE=Release"
- "-DWITH_KF5=FALSE")))
- (native-inputs
- `(("qttools" ,qttools)))
- (inputs
- `(("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)
- ("qtdeclarative" ,qtdeclarative)
- ("qtwebkit" ,qtwebkit)
- ("qtlocation" ,qtlocation)))
- (home-page "https://marble.kde.org/")
- (synopsis "Virtual globe and world atlas")
- (description "Marble is similar to a desktop globe. At closer scale it
+ (package
+ (name "marble-qt")
+ (version "21.08.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://invent.kde.org/education/marble.git/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15gqym45z0gjzdc4ypfj0fki96c3dad4ygsi6lfr8yvwsx8swrb6"))))
+ (build-system qt-build-system)
+ (arguments
+ ;; FIXME: libmarblewidget-qt5.so.28 not found. Also enable the
+ ;; corresponding configure flag to build tests.
+ `(#:tests? #f
+ #:configure-flags
+ '("-DCMAKE_BUILD_TYPE=Release"
+ "-DWITH_KF5=FALSE"
+ "-DBUILD_MARBLE_TESTS=FALSE")))
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (inputs
+ `(("qtbase" ,qtbase-5)
+ ("qtsvg" ,qtsvg)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtwebkit" ,qtwebkit)
+ ("qtlocation" ,qtlocation)))
+ (home-page "https://marble.kde.org/")
+ (synopsis "Virtual globe and world atlas")
+ (description "Marble is similar to a desktop globe. At closer scale it
becomes a world atlas, while OpenStreetMap takes the user to street level. It
supports searching for places of interest, viewing Wikipedia articles,
creating routes by drag and drop and more.")
- (license license:gpl3))))
+ (license license:lgpl2.1+)))
(define-public okular
(package