summaryrefslogtreecommitdiff
path: root/gnu/packages/kde.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-10-19 10:29:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 22:18:20 +0100
commit15cd7067537b9fdae21e7ca7b9e25da4a6476c14 (patch)
tree5ea670c5433a45e442e7200940538592000f64cf /gnu/packages/kde.scm
parent77f144d87ee165490ded1d22082b2b46e77c9c00 (diff)
downloadguix-patches-15cd7067537b9fdae21e7ca7b9e25da4a6476c14.tar
guix-patches-15cd7067537b9fdae21e7ca7b9e25da4a6476c14.tar.gz
gnu: Move kpmcore to kde.scm.
kpmcore is not a framework part. * gnu/packages/kde-frameworks.scm(kpmcore): Move from here … * gnu/packages/kde.scm(kpmcore): … to here.
Diffstat (limited to 'gnu/packages/kde.scm')
-rw-r--r--gnu/packages/kde.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index accf19667d..e81224e8c0 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1,10 +1,12 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -42,6 +44,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-plasma)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
#:use-module (gnu packages maths)
#:use-module (gnu packages pdf)
@@ -464,6 +467,38 @@ including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
cards.")
(license license:lgpl2.1)))
+(define-public kpmcore
+ (package
+ (name "kpmcore")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/kpmcore"
+ "/" version "/src/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0s6v0jfrhjg31ri5p6h9n4w29jvasf5dj954j3vfpzl91lygmmmq"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kconfigwidgets" ,kconfigwidgets)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("ki18n" ,ki18n)
+ ("kservice" ,kservice)
+ ("libatasmart" ,libatasmart)
+ ("parted" ,parted)
+ ("qtbase" ,qtbase)
+ ("util-linux" ,util-linux)))
+ (home-page "https://community.kde.org/Frameworks")
+ (synopsis "Library for managing partitions")
+ (description "Library for managing partitions.")
+ (license license:gpl3+)))
+
(define-public snorenotify
(package
(name "snorenotify")