summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-utils.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-03 23:36:12 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 18:24:56 +0100
commitce288d36878d708863628eb44837ce1221970d30 (patch)
tree9fab4ab6c1dd49e448a754f4bae93d5bc9a93fbb /gnu/packages/kde-utils.scm
parent9b98d288c41cf9b3f305ca11f1961eab0b1605bf (diff)
downloadguix-patches-ce288d36878d708863628eb44837ce1221970d30.tar
guix-patches-ce288d36878d708863628eb44837ce1221970d30.tar.gz
gnu: Add kate.
* gnu/packages/kde-utils.scm: New file. * gnu/local.mk (MODULES): Add it.
Diffstat (limited to 'gnu/packages/kde-utils.scm')
-rw-r--r--gnu/packages/kde-utils.scm94
1 files changed, 94 insertions, 0 deletions
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
new file mode 100644
index 0000000000..1ee0e503a1
--- /dev/null
+++ b/gnu/packages/kde-utils.scm
@@ -0,0 +1,94 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-utils)
+ #:use-module (guix build-system qt)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages kde-plasma)
+ #:use-module (gnu packages qt))
+
+(define-public kate
+ (package
+ (name "kate")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kate-" version ".tar.xz"))
+ (sha256
+ (base32 "0wgcw10c4grkmsyp79ashwgpy59lgrinwdib4mjclpw2grp0g7xb"))))
+ (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kactivities" ,kactivities)
+ ("kconfig" ,kconfig)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kitemmodels" ,kitemmodels)
+ ("threadweaver" ,threadweaver)
+ ("knewstuff" ,knewstuff)
+ ("kio" ,kio)
+ ("kjobwidgets" ,kjobwidgets)
+ ("kparts" ,kparts)
+ ("ktexteditor" ,ktexteditor)
+ ("kwallet" ,kwallet)
+ ("plasma-framework" ,plasma-framework)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)))
+ (arguments
+ `(#:tests? #f ;; 2/7 tests fail
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _
+ ;; make Qt render "offscreen", required for tests
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (setenv "XDG_CACHE_HOME" "/tmp/xdg-cache")
+ #t)))))
+ (home-page "https://kate-editor.org/")
+ (synopsis "Multi-document, multi-view text editor")
+ (description "Kate is a powerful text editor that can open multiple files
+simultaneously.
+
+With a built-in terminal, syntax highlighting, and tabbed sidebar, it performs
+as a lightweight but capable development environment. Kate's many tools,
+plugins, and scripts make it highly customizable.
+
+Kate's features include:
+@itemize
+@item Multiple saved sessions, each with numerous files
+@item Scriptable syntax highlighting, indentation, and code-folding
+@item Configurable templates and text snippets
+@item Symbol viewers for C, C++, and Python
+@item XML completion and validation
+@end itemize")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0))))