summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-utils.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-03 23:50:31 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 18:24:57 +0100
commit6a4bfeb367584f6fad291ef3468f334c250ada15 (patch)
tree3eeaeb662bd4cca94a254c6cce39ad7c6aef0841 /gnu/packages/kde-utils.scm
parentfc1ca667acead8069dd6c2bdf456cf3e6104b31c (diff)
downloadguix-patches-6a4bfeb367584f6fad291ef3468f334c250ada15.tar
guix-patches-6a4bfeb367584f6fad291ef3468f334c250ada15.tar.gz
gnu: Add kmouth.
* gnu/packages/kde-utils.scm (kmouth): New variable.
Diffstat (limited to 'gnu/packages/kde-utils.scm')
-rw-r--r--gnu/packages/kde-utils.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 7f746c310a..94b5496500 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -165,3 +165,44 @@ briefly. It was designed to help those with repetitive strain injuries, for
whom pressing buttons hurts.")
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+
+(define-public kmouth
+ (package
+ (name "kmouth")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kmouth-" version ".tar.xz"))
+ (sha256
+ (base32 "1agjxf1jfi967hj1iz788n6cna6fr7qg80zsx6s119hg7b0xwqmr"))))
+ (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcompletion" ,kcompletion)
+ ("kconfig", kconfig)
+ ("kconfigwidgets", kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("qtspeech" ,qtspeech)))
+ (home-page "https://kde.org/applications/utilities/org.kde.kmouth")
+ (synopsis "Type-and-say frontend for speech synthesizers")
+ (description "KMouth is a program which enables persons that cannot speak
+to let their computer speak, e.g. mutal people or people who have lost their
+voice. It has a text input field and speaks the sentences that you enter. It
+also has support for user defined phrasebooks.
+
+It includes a history of spoken sentences from which the user can select
+sentences to be re-spoken.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))