summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-utils.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-06 16:06:58 +0200
committerMarius Bakke <marius@gnu.org>2020-06-06 22:13:25 +0200
commit6701d2323688d752cdf6e368499dd21f32fb9656 (patch)
treed5e411998bd05b7068c5000898a11f7f0ae26722 /gnu/packages/kde-utils.scm
parentfaa2f1b2df31bd26b033eb738dc07b31d52112b0 (diff)
downloadguix-patches-6701d2323688d752cdf6e368499dd21f32fb9656.tar
guix-patches-6701d2323688d752cdf6e368499dd21f32fb9656.tar.gz
gnu: KDE: Update to 20.04.1.
* gnu/packages/patches/akonadi-paths.patch: Adjust for upstream changes. * gnu/packages/patches/kdepim-runtime-Fix-missing-link-libraries.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/kde-internet.scm (kget, kopete, krdc, libgravatar): Update to 20.04.1. [source](uri): Adjust for new upstream location. * gnu/packages/kde-multimedia.scm (audiocd-kio, dragon, ffmpegthumbs, juk, k3b, kamoso, kmix, kwave, libkcddb, libkcompactdisc): Likewise. * gnu/packages/kde-systemtools.scm (dolphin, dolphin-plugins, khelpcenter, konsole, krfb, ksystemlog): Update to 20.04.1. [source](uri): Adjust for new upstream location. * gnu/packages/kde-utils.scm (kate, kmag, kmousetool, kmouth, sweeper): Update to 20.04.1. [source](uri): Adjust for new upstream location. * gnu/packages/kde.scm (baloo-widgets, libkomparediff2, kqtquickcharts, grantleetheme, kcachegrind, libkdegames, zeroconf-ioslave): Update to 20.04.1. [source](uri): Adjust for new upstream location. (grantleetheme)[inputs]: Add KGUIADDONS. * gnu/packages/kde-pim.scm (akonadi, akonadi-calendar, akonadi-contacts, akonadi-mime, akonadi-notes, akonadi-search, kincidenceeditor, kaddressbook, kalarmcal, kblog, kcalendarsupport, kcalutils, kdav, kdepim-apps-libs, kdepim-runtime, keventviews, kgpg, kidentitymanagement, kimap, kldap, kleopatra, kmail, kmailcommon, kmailimporter, kmailtransport, kmbox, kmessagelib, kmime, knotes, kontactinterface, korganizer, kpimcommon, kpimtextedit, ksmtp, ktnef, libkdepim, libkgapi, libkleo, libksieve): Update to 20.04.1. [source](uri): Adjust to current. (akonadi)[inputs]: Remove KDBUSADDONS and KDESIGNERPLUGIN. (akonadi-calendar)[inputs]: Remove KDBUSADDONS. (kdepim-runtime)[source](patches): Remove. [arguments]: Add phase 'extend-CPLUS_INCLUDE_PATH'. [inputs]: Remove KDBUSADDONS and KICONTHEMES. (kmessagelib)[arguments]: Add phase 'extend-CPLUS_INCLUDE_PATH. [inputs]: Add QCA. (kdepim-apps-libs)[inputs]: Remove KDBUSADDONS and KICONTHEMES. (knotes)[inputs]: Remove KDBUSADDONS. (kpimcommon)[inputs]: Remove KDBUSADDONS and KCOMPLETION. (libksieve)[arguments]: Disable one more test. (korganizer)[arguments]: Disable one test.
Diffstat (limited to 'gnu/packages/kde-utils.scm')
-rw-r--r--gnu/packages/kde-utils.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 38bdfbfaba..f97c03cc61 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -33,14 +33,14 @@
(define-public kate
(package
(name "kate")
- (version "19.08.3")
+ (version "20.04.1")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://kde/stable/applications/" version
+ (uri (string-append "mirror://kde/stable/release-service/" version
"/src/kate-" version ".tar.xz"))
(sha256
- (base32 "0wgcw10c4grkmsyp79ashwgpy59lgrinwdib4mjclpw2grp0g7xb"))))
+ (base32 "0nrby307syrqlxrf9lwdzc9c15ifw47418qwszqwg345ma2pww7i"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -100,14 +100,14 @@ Kate's features include:
(define-public kmag
(package
(name "kmag")
- (version "19.08.3")
+ (version "20.04.1")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://kde/stable/applications/" version
+ (uri (string-append "mirror://kde/stable/release-service/" version
"/src/kmag-" version ".tar.xz"))
(sha256
- (base32 "0l69mgnh2mmkxawwibqdx9n7myl6qqnr2fd3mpsg2bzpcfvmsvi1"))))
+ (base32 "18lk8i2r90gvw8q5j179xgpniih92mwk06krk7w4jv98yinqf6m5"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -131,14 +131,14 @@ artists to web-designers to people with low vision.")
(define-public kmousetool
(package
(name "kmousetool")
- (version "19.08.3")
+ (version "20.04.1")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://kde/stable/applications/" version
+ (uri (string-append "mirror://kde/stable/release-service/" version
"/src/kmousetool-" version ".tar.xz"))
(sha256
- (base32 "169kk20mkm29nycg2vs1k5cs22gzchqs9hbfd661cy2l7n4d8d04"))))
+ (base32 "01j6bx8zihns4ip8maj0gb3w3bhx1ha2ljhfmsm6lcyay531ay98"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -170,14 +170,14 @@ whom pressing buttons hurts.")
(define-public kmouth
(package
(name "kmouth")
- (version "19.08.3")
+ (version "20.04.1")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://kde/stable/applications/" version
+ (uri (string-append "mirror://kde/stable/release-service/" version
"/src/kmouth-" version ".tar.xz"))
(sha256
- (base32 "1agjxf1jfi967hj1iz788n6cna6fr7qg80zsx6s119hg7b0xwqmr"))))
+ (base32 "1afgxlys9mvmc3rd33g7gchfb0ylx83x3x0a0qf3dra6cpgsgcg7"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -475,14 +475,14 @@ Features:
(define-public sweeper
(package
(name "sweeper")
- (version "19.08.3")
+ (version "20.04.1")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://kde/stable/applications/" version
+ (uri (string-append "mirror://kde/stable/release-service/" version
"/src/sweeper-" version ".tar.xz"))
(sha256
- (base32 "1gn87yxmhi7rs82jq7y89bvlx33xbl9wq8kr96pcz423khqvjl84"))))
+ (base32 "1az3c2khnh51bbmqpamj4p26d3a0ff4l5rd3vcrylg94mk7wgh59"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)