summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-systemtools.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-20 22:39:22 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-28 13:08:39 +0100
commit05ddf22c442d10d7f53829d204b91e1eea398510 (patch)
tree2c2b2d1c3336f3c1c4dd02ab102ba7ce8cede89a /gnu/packages/kde-systemtools.scm
parenta4317df4c8a5ca9b13a9caae65836e283d276493 (diff)
downloadguix-patches-05ddf22c442d10d7f53829d204b91e1eea398510.tar
guix-patches-05ddf22c442d10d7f53829d204b91e1eea398510.tar.gz
gnu: Add khelpcenter.
* gnu/packages/kde-systemtools.scm (khelpcenter): New variable.
Diffstat (limited to 'gnu/packages/kde-systemtools.scm')
-rw-r--r--gnu/packages/kde-systemtools.scm46
1 files changed, 45 insertions, 1 deletions
diff --git a/gnu/packages/kde-systemtools.scm b/gnu/packages/kde-systemtools.scm
index 827ab2d7ca..9a7c0f08b8 100644
--- a/gnu/packages/kde-systemtools.scm
+++ b/gnu/packages/kde-systemtools.scm
@@ -26,7 +26,9 @@
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages qt)
- #:use-module (gnu packages ruby))
+ #:use-module (gnu packages ruby)
+ #:use-module (gnu packages search)
+ #:use-module (gnu packages xml))
(define-public dolphin
(package
@@ -114,3 +116,45 @@ The main features of Dolphin are:
(description "This package contains plugins that offer integration in
Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
(license license:gpl2+)))
+
+(define-public khelpcenter
+ (package
+ (name "khelpcenter")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/khelpcenter-" version ".tar.xz"))
+ (sha256
+ (base32 "0ympq1qm5h14mw18wry7l02ndg1f5kddwkf5bliip6vk2vxiff50"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("grantlee" ,grantlee)
+ ("karchive" ,karchive)
+ ("kbookmarks" ,kbookmarks)
+ ("kcodecs" ,kcodecs)
+ ("kconfig" ,kconfig)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdbusaddons" ,kdbusaddons)
+ ("khtml" ,khtml)
+ ("ki18n" ,ki18n)
+ ("kinit" ,kinit)
+ ("kio" ,kio)
+ ("kjs" ,kjs)
+ ("kparts" ,kparts)
+ ("kservice" ,kservice)
+ ("kwindowsystem" ,kwindowsystem)
+ ("libxml2" ,libxml2)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)
+ ("xapian" ,xapian)))
+ (arguments
+ `(#:tests? #f)) ;; 1/1 test fails
+ (home-page "https://kde.org/applications/system/org.kde.Help")
+ (synopsis "KDE documentation viewer")
+ (description "KDE documentation viewer")
+ (license license:gpl2+)))