summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-12 13:16:45 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-12-18 19:17:11 +0100
commitd3f1ef380cee870a7ae5b4f3aee5fad94cb5ad07 (patch)
tree7aea5f3d4035a796d3455e29e722f8e2b804586b /gnu/packages/kde-plasma.scm
parentc4c059ef3fe2914f67db90230c02dcb24a94a054 (diff)
downloadguix-patches-d3f1ef380cee870a7ae5b4f3aee5fad94cb5ad07.tar
guix-patches-d3f1ef380cee870a7ae5b4f3aee5fad94cb5ad07.tar.gz
gnu: breeze: Split from breeze-icons.
KDE breeze is separate from breeze-icons, as it can bee seen by version, download path and git repository path being all different. Thus a package containing both beeze and the breeze-icons contradicts with this upstream separation. * gnu/package/kde.scm (breeze-assets): Remove variable. (breeze): Move to ... * gnu/package/kde-plasme.scm (breeze): here. [version, source]: Copy from former breeze-assets. [build-system]: Make explicit (was inherited even from breeze-icons). [arguments]: Remove. [native-inputs]: New element. [inputs]: Copy from former breeze-assets; add some optional packages. [home-page]: Fix and change to invent.kde.org. [snopysis, description]: Adjust to de-unified package. [licence]: Remove gpl3+, which came from breeze-icons.
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm49
1 files changed, 48 insertions, 1 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index e18d521ad2..33b702539b 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -35,6 +35,53 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
+(define-public breeze
+ (package
+ (name "breeze")
+ (version "5.19.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0dpk1w7zcafrzf46j060i1qb0fwqpsflkfzr6gcar81llmjnc4b1"))))
+ (build-system qt-build-system)
+ ;; TODO: Warning at /gnu/store/…-kpackage-5.34.0/…/KF5PackageMacros.cmake:
+ ;; warnings during generation of metainfo for org.kde.breezedark.desktop:
+ ;; Package type "Plasma/LookAndFeel" not found
+ ;; TODO: Check whether is makes sence splitting into several outputs, like
+ ;; Debian does:
+ ;; - breeze-cursor-theme
+ ;; - "out", "devel"
+ ;; - kde-style-breeze - Widget style
+ ;; - kde-style-breeze-qt4 - propably not useful
+ ;; - kwin-style-breeze
+ ;; - qml-module-qtquick-controls-styles-breeze - QtQuick style
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("kcmutils" ,kcmutils) ; optional
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kde-frameworkintegration" ,kde-frameworkintegration) ; optional
+ ("kdecoration" ,kdecoration)
+ ("kguiaddons" ,kguiaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes) ; for optional kde-frameworkintegration
+ ("kpackage" ,kpackage)
+ ("kwayland" ,kwayland) ; optional
+ ("kwindowsystem" ,kwindowsystem)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative) ; optional
+ ("qtx11extras" ,qtx11extras)))
+ (home-page "https://invent.kde.org/plasma/breeze")
+ (synopsis "Default KDE Plasma theme")
+ (description "Artwork, styles and assets for the Breeze visual style for
+the Plasma Desktop. Breeze is the default theme for the KDE Plasma desktop.")
+ (license license:gpl2+)))
+
(define-public kdecoration
(package
(name "kdecoration")