summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorZ572 <873216071@qq.com>2020-12-18 10:25:51 +0800
committerEfraim Flashner <efraim@flashner.co.il>2020-12-30 12:37:56 +0200
commitc386de05fbcebf7c178327ca98326be20ba6ccb5 (patch)
tree8b4ee5dce88c5e66a23863b0be51fc5159d48b08 /gnu/packages/kde-plasma.scm
parentbd15cd595be239671043a21dff5b809f162a5a9d (diff)
downloadguix-patches-c386de05fbcebf7c178327ca98326be20ba6ccb5.tar
guix-patches-c386de05fbcebf7c178327ca98326be20ba6ccb5.tar.gz
gnu: Add ksshaskpass.
* gnu/packages/kde-plasma.scm (ksshaskpass): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 33b702539b..c64d8ae39f 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -106,6 +107,35 @@ These window decorations can be used by for example an X11 based window
manager which re-parents a Client window to a window decoration frame.")
(license license:lgpl3+)))
+(define-public ksshaskpass
+ (package
+ (name "ksshaskpass")
+ (version "5.19.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/ksshaskpass-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1k2va2v9051f71w78dn3gihk642iyy5yzrkcfnp97fag8g6dpisi"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kwallet" ,kwallet)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("qtbase" ,qtbase)))
+ (home-page "https://invent.kde.org/plasma/ksshaskpass")
+ (synopsis "Front-end for ssh-add using kwallet")
+ (description "Ksshaskpass is a front-end for @code{ssh-add} which stores the
+password of the ssh key in KWallet. Ksshaskpass is not meant to be executed
+directly, you need to tell @code{ssh-add} about it. @code{ssh-add} will then
+call it if it is not associated to a terminal.")
+ (license license:gpl2+)))
+
(define-public kscreenlocker
(package
(name "kscreenlocker")