summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-plasma.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-06-09 13:12:08 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-12 23:49:02 +0100
commit6a97dfff19cce5cee2c779efcb9c3ff93076f81c (patch)
treef6de262478132255462ec6d02dc5b8a7d576bf8a /gnu/packages/kde-plasma.scm
parent856e3f9cb4dc3bc9c13a06f20d84df70e11213a3 (diff)
downloadguix-patches-6a97dfff19cce5cee2c779efcb9c3ff93076f81c.tar
guix-patches-6a97dfff19cce5cee2c779efcb9c3ff93076f81c.tar.gz
gnu: Add kdecoration.
* gnu/packages/kde-plasma.scm (kdecoration): New public variable. Co-authored-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/kde-plasma.scm')
-rw-r--r--gnu/packages/kde-plasma.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index ff6fa64a17..c8e1f610bb 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1,6 +1,8 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +31,36 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages xorg))
+(define-public kdecoration
+ (package
+ (name "kdecoration")
+ (version "5.14.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/plasma/" version
+ "/kdecoration-" version ".tar.xz"))
+ (sha256
+ (base32
+ "115pli0qpa8lx0jasg1886fcg7gb2kk8v6k8r8l8c820l97sq7in"))))
+ (properties `((tags . '("Desktop" "KDE" "Plasma"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("ki18n" ,ki18n)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'check-setup
+ (lambda _ (setenv "QT_QPA_PLATFORM" "offscreen") #t)))))
+ (home-page "https://cgit.kde.org/kdecoration.git")
+ (synopsis "Plugin based library to create window decorations")
+ (description "KDecoration is a library to create window decorations.
+These window decorations can be used by for example an X11 based window
+manager which re-parents a Client window to a window decoration frame.")
+ (license license:lgpl3+)))
+
(define-public libkscreen
(package
(name "libkscreen")