summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-04-09 21:53:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-06-14 00:24:42 -0400
commitea0a51071e68c37a4c9c25421cf03bc2f442c67b (patch)
treec30587b862169414a2170b86aae6ba4dbc5a2796 /gnu/packages/kde-pim.scm
parent0b5120fb03db5226871b3482a72b1e6fdaa59ead (diff)
downloadguix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar
guix-patches-ea0a51071e68c37a4c9c25421cf03bc2f442c67b.tar.gz
gnu: Rename qtbase to qtbase-5.
This change was automated via the following command: $ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g' $ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g' $ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g' $ git checkout etc # to clear some spurious changes This is done so the qtbase package can be upgraded to version 6 in the following commit.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm80
1 files changed, 40 insertions, 40 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 74e8bdb8fd..db73941b42 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -79,7 +79,7 @@
;; Do NOT add mysql or postgresql to the inputs. Otherwise the binaries
;; and wrapped files will refer to them, even if the user choices none
;; of these. Executables are searched on $PATH then.
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("sqlite" ,sqlite)))
(arguments
`(#:tests? #f ;; TODO 135/167 tests fail
@@ -151,7 +151,7 @@ programs.")
("ksmtp" ,ksmtp)
("ktextwidgets" ,ktextwidgets)
("kwallet" ,kwallet)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:tests? #f)) ;; TODO: 1/1 test fails
(home-page "https://api.kde.org/kdepim/akonadi/html/index.html")
@@ -196,7 +196,7 @@ collection and item views.")
("kxmlgui" ,kxmlgui)
("prison" ,prison)
("kio" ,kio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("solid" ,solid)
("sonnet" ,sonnet)))
(home-page "https://api.kde.org/kdepim/akonadi/html/index.html")
@@ -240,7 +240,7 @@ to list and filter contacts.")
("kmime" ,kmime)
("kwidgetsaddons" ,kwidgetsaddons)
("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/kdepim/akonadi/html/index.html")
(arguments
`(#:phases
@@ -283,7 +283,7 @@ with emails through Akonadi easier.")
("kcodecs" ,kcodecs)
("ki18n" ,ki18n)
("kmime" ,kmime)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/kdepim/akonadi/html/index.html")
(synopsis "Akonadi notes access library")
(description "Akonadi Notes is a library that effectively bridges the
@@ -325,7 +325,7 @@ wrapping notes into KMime::Message objects.")
("kmime" ,kmime)
("krunner" ,krunner)
("kwindowsystem" ,kwindowsystem)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("xapian" ,xapian)))
(arguments
`(#:phases (modify-phases %standard-phases
@@ -390,7 +390,7 @@ Akonadi PIM data server. It uses Xapian for indexing and querying.")
("ktextwidgets" ,ktextwidgets)
("kwallat" ,kwallet)
("libkdepim" ,libkdepim)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/incidenceeditor")
(synopsis "KDE PIM library for editing incidences")
(description "This library provides an incidence editor for KDE PIM.")
@@ -445,7 +445,7 @@ Akonadi PIM data server. It uses Xapian for indexing and querying.")
("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
("prison" ,prison)
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://kontact.kde.org/components/kaddressbook.html")
(synopsis "Address Book application to manage your contacts")
(description "KAddressBook stores all the personal details of your family,
@@ -486,7 +486,7 @@ CalDAV server.")
("kpimtextedit" ,kpimtextedit)
("ktextwidgets" ,ktextwidgets)
("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:tests? #f)) ;; TODO: TZ setup
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
@@ -515,7 +515,7 @@ calendar data.")
("ki18n" ,ki18n)
("kio" ,kio)
("kxmlrpcclient" ,kxmlrpcclient)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("syndication" ,syndication)))
;; Note: Some tests take up to 90 sec.
(home-page "https://invent.kde.org/pim/kblog")
@@ -567,7 +567,7 @@ one of the APIs mentioned above.")
("kpimtextedit" ,kpimtextedit)
("ktextwidgets" ,ktextwidgets)
("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/stable/calendarsupport/")
(synopsis "Calendar Support library for KDE PIM")
(description "The Calendar Support library provides helper utilities for
@@ -604,7 +604,7 @@ calendaring applications.")
("ktextwidgets" ,ktextwidgets)
("kwidgetsaddons" ,kwidgetsaddons)
("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:tests? #f)) ;; TODO: seem to pull in some wrong theme
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
@@ -632,7 +632,7 @@ functions for accessing calendar data using the kcalcore API.")
`(("kcoreaddons" ,kcoreaddons)
("ki18n" ,ki18n)
("kio" ,kio)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtxmlpatterns" ,qtxmlpatterns)))
(home-page "https://invent.kde.org/frameworks/kdav")
(synopsis "DAV protocol implementation with KJobs")
@@ -678,7 +678,7 @@ supported using GroupDAV or CardDAV.")
("libkleo" ,libkleo)
("prison" ,prison)
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/kdepim-apps-libs")
(synopsis "KDE PIM mail related libraries and data files")
(description "This package provides mail related libraries and data files
@@ -739,7 +739,7 @@ for KDE PIM.")
("libkgapi" ,libkgapi)
;; TODO: libkolab
("qca" ,qca)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtnetworkauth" ,qtnetworkauth)
("qtspeech" ,qtspeech)
@@ -815,7 +815,7 @@ package.")
("ktextwidgets" ,ktextwidgets)
("kxmlgui" ,kxmlgui)
("libkdepim" ,libkdepim)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/eventviews")
(synopsis "KDE PIM library for creating events")
(description "This library provides an event creator for KDE PIM.")
@@ -861,7 +861,7 @@ package.")
("kwindowsystem" ,kwindowsystem)
("kxmlgui" ,kxmlgui)
("oxygen-icons" ,oxygen-icons) ;; default icon set
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://kde.org/applications/utilities/org.kde.kgpg")
(synopsis "Graphical front end for GNU Privacy Guard")
(description "Kgpg manages cryptographic keys for the GNU Privacy Guard,
@@ -895,7 +895,7 @@ cryptography to the contents of the clipboard.")
("kpimtextedit" ,kpimtextedit)
("ktextwidgets" ,ktextwidgets)
("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -929,7 +929,7 @@ cryptography to the contents of the clipboard.")
("ki18n" ,ki18n)
("kio" ,kio)
("kmime" ,kmime)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
(synopsis "Library for handling IMAP")
(description "This library provides a job-based API for interacting with
@@ -959,7 +959,7 @@ easier to do so.")
`(("ki18n" ,ki18n)
("kio" ,kio)
("kwidgetsaddons" ,kwidgetsaddons)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(propagated-inputs
`(("cyrus-sasl" ,cyrus-sasl)
("openldap" ,openldap)))
@@ -1010,7 +1010,7 @@ protocol for querying and modifying directory services running over TCP/IP. ")
("libkleo" ,libkleo)
("oxygen-icons" ,oxygen-icons) ;; default icon set
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1096,7 +1096,7 @@ and retrieving certificates from LDAP servers.")
("libksieve" ,libksieve)
("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtwebchannel" ,qtwebchannel)
("qtwebengine" ,qtwebengine)
@@ -1177,7 +1177,7 @@ manager from KDE.")
("libxslt" ,libxslt)
("phonon" ,phonon)
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:tests? #f)) ;; TODO: 4/56 tests fail, even with "offscreen" and dbus
(home-page "https://invent.kde.org/pim/mailcommon")
@@ -1218,7 +1218,7 @@ dealing with email.")
("kmime" ,kmime)
("kxmlgui" ,kxmlgui)
("libkdepim" ,libkdepim)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/mailimporter")
(synopsis "KDE mail importer library")
(description "This package provides libraries for importing mails other
@@ -1259,7 +1259,7 @@ e-mail client programs into KMail and KDE PIM.")
("ktextwidgets" ,ktextwidgets)
("kwallet" ,kwallet)
("libkgapi" ,libkgapi)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:tests? #f)) ;; TODO - 3/3 tests fail, require drkonqi
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
@@ -1285,7 +1285,7 @@ mail transport.")
(inputs
`(("kcodecs" ,kcodecs)
("kmime" ,kmime)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
(synopsis "Library for handling mbox mailboxes")
(description "This is a library for handling mailboxes in mbox format,
@@ -1355,7 +1355,7 @@ using a Qt/KMime C++ API.")
("libkleo" ,libkleo)
("qca" ,qca)
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtwebchannel" ,qtwebchannel)
("qtwebengine" ,qtwebengine)
@@ -1398,7 +1398,7 @@ kwebengineviewer.")
(inputs
`(("kcodecs" ,kcodecs)
("ki18n" ,ki18n)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1475,7 +1475,7 @@ information in non-ASCII character sets.")
("kxmlgui" ,kxmlgui)
("libkdepim" ,libkdepim)
("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtx11extras" ,qtx11extras)))
(home-page "https://kontact.kde.org/components/knotes.html")
(synopsis "Note-taking utility")
@@ -1513,7 +1513,7 @@ Features:
("kparts" ,kparts)
("kwindowsystem" ,kwindowsystem)
("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
(synopsis "Kontact interface library")
(description " This library provides the glue necessary for
@@ -1584,7 +1584,7 @@ application \"Parts\" to be embedded as a Kontact component (or plugin).")
("libkdepim" ,libkdepim)
("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
("phonon" ,phonon)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1639,7 +1639,7 @@ and exchanging calendar data, vCalendar and iCalendar.")
(inputs
`(("kcontacts" ,kcontacts)
("kpeople" ,kpeople)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/kpeoplevcard")
(synopsis "Expose vCard contacts to KPeople")
(description
@@ -1697,7 +1697,7 @@ Virtual Contact File}) files to the KPeople contact management library.")
("libkdepim" ,libkdepim)
("libxslt" ,libxslt)
("purpose" ,purpose)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtwebengine" ,qtwebengine)))
(arguments
`(#:tests? #f)) ;; TODO tests hang
@@ -1736,7 +1736,7 @@ Virtual Contact File}) files to the KPeople contact management library.")
("ktextwidgets" ,ktextwidgets)
("kwidgetsaddons" ,kwidgetsaddons)
("kxmlgui" ,kxmlgui)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtspeech" ,qtspeech)
("sonnet" ,sonnet)))
(arguments
@@ -1770,7 +1770,7 @@ text in the text edit to all kinds of markup, like HTML or BBCODE.")
("kcoreaddons" ,kcoreaddons)
("ki18n" ,ki18n)
("kio" ,kio)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(arguments
`(#:tests? #f ;; TODO: does not find sasl mechs
#:phases
@@ -1811,7 +1811,7 @@ standard protocols for e-mail transmission.")
("kcontacts" ,kcontacts)
("kcoreaddons" ,kcoreaddons)
("ki18n" ,ki18n)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://api.kde.org/stable/kdepimlibs-apidocs/ktnef/html/")
(synopsis "Library for handling mail attachments using TNEF format")
(description "Ktnef is a library for handling data in the TNEF
@@ -1862,7 +1862,7 @@ and allows one to view/extract message formatted text in Rich Text Format.")
("kmime" ,kmime)
("kwallet" ,kwallet)
("kwidgetsaddons" ,kwidgetsaddons)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/libkdepim")
(synopsis "Libraries for common KDE PIM apps")
(description "This package provided libraries for common KDE PIM apps.")
@@ -1892,7 +1892,7 @@ and allows one to view/extract message formatted text in Rich Text Format.")
("kio" ,kio)
("kwallet" ,kwallet)
("kwindowsystem" ,kwindowsystem)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtwebchannel" ,qtwebchannel)
("qtwebengine" ,qtwebengine)))
@@ -1935,7 +1935,7 @@ various Google services.")
("kwindowsystem" ,kwindowsystem)
("kpimtextedit" ,kpimtextedit)
("qgpgme" ,qgpgme)
- ("qtbase" ,qtbase)))
+ ("qtbase" ,qtbase-5)))
(home-page "https://invent.kde.org/pim/libkleo")
(synopsis "KDE PIM cryptographic library")
(description "@code{libkleo} is a library for Kleopatra and other parts of
@@ -1978,7 +1978,7 @@ KDE using certificate-based crypto.")
("kwallet" ,kwallet)
("kwindowsystem" ,kwindowsystem)
("libkdepim" ,libkdepim)
- ("qtbase" ,qtbase)
+ ("qtbase" ,qtbase-5)
("qtdeclarative" ,qtdeclarative)
("qtwebchannel" ,qtwebchannel)
("qtwebengine" ,qtwebengine)))