summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 23:16:13 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:26 +0100
commitd03ad6cf778e83e6b4bb633805fc384786900a21 (patch)
tree8dd4d3012334f0ffb06b0d64d886a235dc99476a /gnu/packages/kde-pim.scm
parent8d41c6a3b58eac788aae8dcb8f256b6c423deef3 (diff)
downloadguix-patches-d03ad6cf778e83e6b4bb633805fc384786900a21.tar
guix-patches-d03ad6cf778e83e6b4bb633805fc384786900a21.tar.gz
gnu: Add akonadi-notes.
* gnu/packages/kde-pim.scm (akonadi-notes): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 76e49da124..9d6a13edcd 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -166,6 +166,35 @@ with emails through Akonadi easier.")
(license ;; GPL for programs, LGPL for libraries
(list license:gpl2+ license:lgpl2.0+))))
+(define-public akonadi-notes
+ (package
+ (name "akonadi-notes")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/akonadi-notes-" version ".tar.xz"))
+ (sha256
+ (base32 "0r8vh11bfjzhspb5kp2d0kcgwqd2m5qpxpamiajzjq910f51sw3w"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("kcodecs" ,kcodecs)
+ ("ki18n" ,ki18n)
+ ("kmime" ,kmime)
+ ("qtbase" ,qtbase)))
+ (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/akonadi/html/")
+ (synopsis "Akonadi notes access library")
+ (description "Akonadi Notes is a library that effectively bridges the
+type-agnostic API of the Akonadi client libraries and the domain-specific
+KMime library. It provides a helper class for note attachments and for
+wrapping notes into KMime::Message objects.")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kalarmcal
(package
(name "kalarmcal")