summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-06 20:57:50 +0200
committerMarius Bakke <marius@gnu.org>2020-06-06 21:14:17 +0200
commitb69ca4d234db8fe2750e9b0d6b6139a5a89a4da6 (patch)
tree3c0fbcab3167b48661adee3470bafbed39a6c29b /gnu/packages/kde-pim.scm
parent9c0fd3d34cab839411ba47312eba6b659d5213ae (diff)
downloadguix-patches-b69ca4d234db8fe2750e9b0d6b6139a5a89a4da6.tar
guix-patches-b69ca4d234db8fe2750e9b0d6b6139a5a89a4da6.tar.gz
gnu: Add kpeoplevcard.
* gnu/packages/kde-pim.scm (kpeoplevcard): New public variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 0d6ab36c15..569ac43d91 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1595,6 +1595,37 @@ and exchanging calendar data, vCalendar and iCalendar.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kpeoplevcard
+ (package
+ (name "kpeoplevcard")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.kde.org/stable/kpeoplevcard/"
+ version "/kpeoplevcard-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hv3fq5k0pps1wdvq9r1zjnr0nxf8qc3vwsnzh9jpvdy79ddzrcd"))))
+ (build-system qt-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (replace 'check-setup
+ (lambda _
+ (setenv "HOME" "/tmp")
+ #t)))))
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kcontacts" ,kcontacts)
+ ("kpeople" ,kpeople)
+ ("qtbase" ,qtbase)))
+ (home-page "https://invent.kde.org/pim/kpeoplevcard")
+ (synopsis "Expose vCard contacts to KPeople")
+ (description
+ "This plugins adds support for vCard (also known as @acronym{VCF,
+Virtual Contact File}) files to the KPeople contact management library.")
+ (license license:lgpl2.1+)))
+
(define-public kpimcommon
(package
(name "kpimcommon")