summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-27 11:46:19 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-27 11:48:16 +0100
commit9204408de706e1304428b6817fad69395834ad37 (patch)
tree248475e286553706eccf11a0c892f1fbac8617be /gnu/packages/kde-pim.scm
parent54b0b96c5b297e39580bc0367d5908833fe69ca7 (diff)
downloadguix-patches-9204408de706e1304428b6817fad69395834ad37.tar
guix-patches-9204408de706e1304428b6817fad69395834ad37.tar.gz
gnu: akonadi: Remove references to '%outputs' and '%build-inputs'.
* gnu/packages/kde-pim.scm (akonadi)[arguments]: Remove references to '%outputs' and '%build-inputs'.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index d0e67fa37a..b63f72f071 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -90,10 +90,10 @@
#:phases
(modify-phases (@ (guix build qt-build-system) %standard-phases)
(add-before 'configure 'add-definitions
- (lambda _
- (let ((out (assoc-ref %outputs "out"))
- (mysql (assoc-ref %build-inputs "mysql"))
- (pgsql (assoc-ref %build-inputs "postgresql")))
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (mysql (assoc-ref inputs "mysql"))
+ (pgsql (assoc-ref inputs "postgresql")))
(with-output-to-file "CMakeLists.txt.new"
(lambda _
(display