summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 19:49:11 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:22 +0100
commit7cfb118cbe77cc9d351b9ad42d0cde93ba29be31 (patch)
tree0a9bebb269c715a1b9327076cfcfff8c090ef183 /gnu/packages/kde-pim.scm
parente35b50ecdd553f3fac4d16db311149dbcc3028fe (diff)
downloadguix-patches-7cfb118cbe77cc9d351b9ad42d0cde93ba29be31.tar
guix-patches-7cfb118cbe77cc9d351b9ad42d0cde93ba29be31.tar.gz
gnu: Add kmime.
* gnu/packages/kde-pim.scm (kmime): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 3bf3e96a02..393ffaba7e 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -110,3 +110,37 @@ data.
This package contains the Akonadi PIM storage server and associated
programs.")
(license license:fdl1.2+)))
+
+(define-public kmime
+ (package
+ (name "kmime")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kmime-" version ".tar.xz"))
+ (sha256
+ (base32 "1pc00pwwrngsyr7ppvqwfgvcgy2wiqdbqxhv9xidn4dw9way2ng6"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("kcodecs" ,kcodecs)
+ ("ki18n" ,ki18n)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-test-case
+ (lambda _
+ ;; This is curious: autotests/CMakeLists.txt sets LC_TIME=C, but
+ ;; the Qt locale returns different. See kmime commit 3a9651d26a.
+ (substitute* "autotests/dateformattertest.cpp"
+ (("(Today|Yesterday) 12:34:56" line day)
+ (string-append day " 12:34 PM")))
+ #t)))))
+ (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+ (synopsis "Library for handling MIME data")
+ (description "A library for MIME handling.")
+ (license license:lgpl2.0+)))