summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-17 01:25:52 +0200
committerMarius Bakke <marius@gnu.org>2021-09-17 01:25:52 +0200
commit5c3cb22c9b2810669999e044b2de5e9331011a83 (patch)
tree3276e19cc1a0af3cece6ce4f2bfa930901888bb4 /gnu/packages/kde-pim.scm
parentc896287ce5eff968a0b323f3a069653a64b96b4c (diff)
parent2a054d29dcfd4b68ed3914886b637f93ac7a0a72 (diff)
downloadguix-patches-5c3cb22c9b2810669999e044b2de5e9331011a83.tar
guix-patches-5c3cb22c9b2810669999e044b2de5e9331011a83.tar.gz
Merge branch 'master' into core-updates-frozen
Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 0c7fa77b1e..d0e67fa37a 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -339,8 +340,9 @@ wrapping notes into KMime::Message objects.")
""))
#t))
(replace 'check
- (lambda _
- (invoke "dbus-launch" "ctest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-launch" "ctest")))))))
(home-page "https://api.kde.org/kdepim/akonadi/html/index.html")
(synopsis "Akonadi search library")
(description "This package provides a library used to search in the
@@ -1014,8 +1016,9 @@ protocol for querying and modifying directory services running over TCP/IP. ")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "dbus-launch" "ctest" ".")
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-launch" "ctest" "."))
#t)))))
(home-page "https://kde.org/applications/utilities/org.kde.kleopatra")
(synopsis "Certificate Manager and Unified Crypto GUI")
@@ -1104,8 +1107,9 @@ and retrieving certificates from LDAP servers.")
`(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "dbus-launch" "ctest" ".")
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-launch" "ctest" "."))
#t)))))
(home-page "https://kontact.kde.org/components/kmail.html")
(synopsis "Full featured graphical email client")
@@ -1596,8 +1600,9 @@ application \"Parts\" to be embedded as a Kontact component (or plugin).")
""))
#t))
(replace 'check
- (lambda _
- (invoke "dbus-launch" "ctest" ".")
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-launch" "ctest" "."))
#t)))))
(home-page "https://kontact.kde.org/components/korganizer.html")
(synopsis "Organizational assistant, providing calendars and other similar