summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-09-13 11:04:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-09-13 15:04:33 +0300
commit5bde487831b8227afa185bb13c2444833036d66c (patch)
tree2a6ca8a26ed17256bb4bb8019920e8f91e1291bf /gnu/packages/kde-pim.scm
parentec0e05ff306c950142c9ead7c712c749617069e7 (diff)
downloadguix-patches-5bde487831b8227afa185bb13c2444833036d66c.tar
guix-patches-5bde487831b8227afa185bb13c2444833036d66c.tar.gz
gnu: akonadi-search: Allow skipping tests.
* gnu/packages/kde-pim.scm (akonadi-search)[arguments]: Have custom 'check phase honor #:tests?.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index db73941b42..5d610143a7 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -339,8 +340,9 @@ wrapping notes into KMime::Message objects.")
""))
#t))
(replace 'check
- (lambda _
- (invoke "dbus-launch" "ctest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "dbus-launch" "ctest")))))))
(home-page "https://api.kde.org/kdepim/akonadi/html/index.html")
(synopsis "Akonadi search library")
(description "This package provides a library used to search in the