summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-03 23:42:10 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:30 +0100
commit48d5d0ef1c05e3655909b907c2ac166114bbe19a (patch)
tree5bbeb911c844eb1cb9e88d76573ded6124d97e3d /gnu/packages/kde-pim.scm
parentba4f9352c175092e5145e22cf9d4c9882170d293 (diff)
downloadguix-patches-48d5d0ef1c05e3655909b907c2ac166114bbe19a.tar
guix-patches-48d5d0ef1c05e3655909b907c2ac166114bbe19a.tar.gz
gnu: Add kgpg.
* gnu/packages/kde-utils.scm (kgpg): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 4bb4c85b55..d2b6beb55a 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -412,6 +412,54 @@ data")
functions for accessing calendar data using the kcalcore API.")
(license license:lgpl2.0+)))
+(define-public kgpg
+ (package
+ (name "kgpg")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kgpg-" version ".tar.xz"))
+ (sha256
+ (base32 "1dis7zv51a4lhx5l3wlwnhym8f79h8sibhhk97fkn8d7szdrmfw5"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("gnupg" ,gnupg) ;; TODO: Remove after gpgme uses fixed path
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("akonadi" ,akonadi)
+ ("akonadi-contacts" ,akonadi-contacts)
+ ("boost" ,boost)
+ ("gpgme" ,gpgme)
+ ("karchive" ,karchive)
+ ("kcodecs" ,kcodecs)
+ ("kcontacts" ,kcontacts)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kitemmodels" ,kitemmodels)
+ ("kjobwidgets" ,kjobwidgets)
+ ("knotifications" ,knotifications)
+ ("kservice" ,kservice)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/utilities/org.kde.kgpg")
+ (synopsis "Graphical front end for GNU Privacy Guard")
+ (description "Kgpg manages cryptographic keys for the GNU Privacy Guard,
+and can encrypt, decrypt, sign, and verify files. It features a simple editor
+for applying cryptography to short pieces of text, and can also quickly apply
+cryptography to the contents of the clipboard.")
+ (license license:gpl2+)))
+
(define-public kidentitymanagement
(package
(name "kidentitymanagement")