summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 22:52:57 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:24 +0100
commit037994df433ab82c705d214cf917589414df353e (patch)
treef20bfa10f0088211fcbebd1a03e3fcd621361673 /gnu/packages/kde-pim.scm
parent0a0df84f0b2d29b79e84e5f508a801c7b011cef6 (diff)
downloadguix-patches-037994df433ab82c705d214cf917589414df353e.tar
guix-patches-037994df433ab82c705d214cf917589414df353e.tar.gz
gnu: Add kimap.
* gnu/packages/kde-pim.scm (kimap): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index b0bd75685e..0eb1c10747 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -24,6 +24,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
#:use-module (gnu packages gnome)
@@ -189,6 +190,37 @@ functions for accessing calendar data using the kcalcore API.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public kimap
+ (package
+ (name "kimap")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kimap-" version ".tar.xz"))
+ (sha256
+ (base32 "0l8hb2z82jzbwr12lw5fismwk1a3ca4dk966p1fxg4bibck8vjj6"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)))
+ (inputs
+ `(("cyrus-sasl" ,cyrus-sasl)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kmime" ,kmime)
+ ("qtbase" ,qtbase)))
+ (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+ (synopsis "Library for handling IMAP")
+ (description "This library provides a job-based API for interacting with
+an IMAP4rev1 server. It manages connections, encryption and parameter quoting
+and encoding, but otherwise provides quite a low-level interface to the
+protocol. This library does not implement an IMAP client; it merely makes it
+easier to do so.")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kmbox
(package
(name "kmbox")