summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-multimedia.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-08 18:08:57 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-26 16:44:53 +0100
commitca632dc175c085316749d1605acf9719c8f6085e (patch)
treed7d5d7fcea1478cafe20f9ff4b93d845c5a46b24 /gnu/packages/kde-multimedia.scm
parentabd4d5785127ac45de0718cee77db6cbfb7e0a00 (diff)
downloadguix-patches-ca632dc175c085316749d1605acf9719c8f6085e.tar
guix-patches-ca632dc175c085316749d1605acf9719c8f6085e.tar.gz
gnu: Add kamoso.
* gnu/packages/kde-multimedia.scm (kamoso): New variable.
Diffstat (limited to 'gnu/packages/kde-multimedia.scm')
-rw-r--r--gnu/packages/kde-multimedia.scm48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index 6a2ce1909f..345f2042c1 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages glib)
#:use-module (gnu packages gtk)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gstreamer)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages libcanberra)
#:use-module (gnu packages linux)
@@ -324,6 +325,53 @@ autoloading of subtitle files for use while playing video.")
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+(define-public kamoso
+ (package
+ (name "kamoso")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kamoso-" version ".tar.xz"))
+ (sha256
+ (base32 "0j0lr2gwaxwchgfp54dashm1b39gsaw4ly9p8ybavwwzhjkdqza3"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("glib:bin" ,glib "bin")
+ ("kdoctools" ,kdoctools)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("kconfig" ,kconfig)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kirigami" ,kirigami)
+ ("knotifications" ,knotifications)
+ ("kparts" ,kparts)
+ ("oxygen-icons" ,oxygen-icons) ; default icon set
+ ("purpose" ,purpose)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("qtgraphicaleffects" ,qtgraphicaleffects)
+ ("qtquickcontrols" ,qtquickcontrols)
+ ("qtquickcontrols2" ,qtquickcontrols2) ; not listed as dependency
+ ("qtx11extras" ,qtx11extras)))
+ (arguments
+ `(#:tests? #f ; test program gets built, but is not found
+ #:configure-flags
+ (list (string-append "-DCMAKE_CXX_FLAGS=-I"
+ (assoc-ref %build-inputs "gst-plugins-base")
+ "/include/gstreamer-1.0"))))
+ (home-page "https://kde.org/applications/multimedia/org.kde.kamoso")
+ (synopsis "Take pictures and videos out of your webcam")
+ (description "Kamoso is a simple and friendly program to use your
+camera. Use it to take pictures and make videos to share.")
+ (license ;; GPL for programs, LGPL for libraries
+ (list license:gpl2+ license:lgpl2.0+))))
+
(define-public kmix
(package
(name "kmix")