summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-multimedia.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-08 19:09:10 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-26 16:44:54 +0100
commitb291c9570d5a27b11472df3df61cef9ed012241b (patch)
tree6fb3c564beb867a1d4db13c5a8977363cf124838 /gnu/packages/kde-multimedia.scm
parent2d11fbcf10752866281cc25505cd299d656ff0e6 (diff)
downloadguix-patches-b291c9570d5a27b11472df3df61cef9ed012241b.tar
guix-patches-b291c9570d5a27b11472df3df61cef9ed012241b.tar.gz
gnu: Add ffmpegthumbs.
* gnu/packages/kde-multimedia.scm (ffmpegthumbs): New variable.
Diffstat (limited to 'gnu/packages/kde-multimedia.scm')
-rw-r--r--gnu/packages/kde-multimedia.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index 0426d0c0a0..e87df550a9 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -198,6 +198,37 @@ The Baloo one is much faster because Baloo is providing all needed data from
its own database. You can build and play your own playlist.")
(license license:lgpl3+)))
+(define-public ffmpegthumbs
+ (package
+ (name "ffmpegthumbs")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/ffmpegthumbs-" version ".tar.xz"))
+ (sha256
+ (base32 "1w6070ng40nf99wpl6p5s8nx0icfx2c26vvnz4f9fx7l7pldh6n9"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("ffmpeg" ,ffmpeg)
+ ("kconfig" ,kconfig)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/multimedia/org.kde.ffmpegthumbs")
+ (synopsis "Video thumbnail generator for KDE using ffmpeg")
+ (description "
+FFMpegThumbs is a video thumbnail generator for KDE file managers
+like Dolphin and Konqueror. It enables them to show preview images
+of video files using FFMpeg.
+
+This package is part of the KDE multimedia module.")
+ (license license:gpl2+)))
+
(define-public juk
(package
(name "juk")