summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-multimedia.scm
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-06-17 12:50:05 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-21 17:36:40 +0200
commit7afaab8befef57a8358e4a5881508fb278d18733 (patch)
tree9604856404b1ba62629a8ceb4f05484fe38ac1e8 /gnu/packages/kde-multimedia.scm
parentf458958543c0db5744c70ee4bc655b6627af24ac (diff)
downloadguix-patches-7afaab8befef57a8358e4a5881508fb278d18733.tar
guix-patches-7afaab8befef57a8358e4a5881508fb278d18733.tar.gz
gnu: k3b: Add inputs for external programs.
* gnu/packages/kde-multimedia.scm (k3b)[inputs]: Add cdrdao, dvd+rw-tools, libburn and sox. [arguments]<#:phases>[wrap-path]: New phase to wrap the binary with paths to the above. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/kde-multimedia.scm')
-rw-r--r--gnu/packages/kde-multimedia.scm19
1 files changed, 18 insertions, 1 deletions
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index 938251a532..654aecd858 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -296,12 +297,26 @@ This package is part of the KDE multimedia module.")
(sha256
(base32 "0r01ninrrmqk7pl5jg0g51fcky1ammw0yyq572wyhibw7q8y7ly7"))))
(build-system qt-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'qt-wrap 'wrap-path
+ (lambda _
+ ;; Set paths to backend programs.
+ (wrap-program (string-append (assoc-ref %outputs "out") "/bin/k3b")
+ `("PATH" ":" prefix
+ ,(map (lambda (input)
+ (string-append (assoc-ref %build-inputs input) "/bin"))
+ '("cdrdao" "dvd+rw-tools" "libburn" "sox"))))
+ #t)))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)
("kdoctools" ,kdoctools)))
(inputs
- `(("ffmpeg" ,ffmpeg)
+ `(("cdrdao" ,cdrdao)
+ ("dvd+rw-tools" ,dvd+rw-tools)
+ ("ffmpeg" ,ffmpeg)
("flac" ,flac)
("karchive" ,karchive)
("kcmutils" ,kcmutils)
@@ -319,6 +334,7 @@ This package is part of the KDE multimedia module.")
("kwidgetsaddons" ,kwidgetsaddons)
("kxmlgui" ,kxmlgui)
("lame" ,lame)
+ ("libburn" ,libburn)
("libdvdread" ,libdvdread)
;; TODO: LibFuzzer
("libiconv" ,libiconv)
@@ -334,6 +350,7 @@ This package is part of the KDE multimedia module.")
("qtwebkit" ,qtwebkit)
("shared-mime-info" ,shared-mime-info)
("solid" ,solid)
+ ("sox" ,sox)
("taglib" ,taglib)))
(home-page "https://kde.org/applications/multimedia/org.kde.k3b")
(synopsis "Sophisticated CD/DVD burning application")