summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-multimedia.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-04 10:10:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-04 10:10:41 +0200
commit6f365f7c10938fc7bc609f95a79893585843454d (patch)
treed3d93e51cf3ccbc1a22304fbabba7537666541d6 /gnu/packages/kde-multimedia.scm
parentfdfc1c81ba018dd808b0dfd9827a73262c716808 (diff)
downloadguix-patches-6f365f7c10938fc7bc609f95a79893585843454d.tar
guix-patches-6f365f7c10938fc7bc609f95a79893585843454d.tar.gz
gnu: elisa: Update to 20.12.0.
* gnu/packages/kde-multimedia.scm (elisa): Update to 20.12.0. [source]: Use new upstream source URI. [arguments]: Replace 'check phase.
Diffstat (limited to 'gnu/packages/kde-multimedia.scm')
-rw-r--r--gnu/packages/kde-multimedia.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index cc312b6c40..cb8cc74d33 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -133,14 +134,14 @@ This package is part of the KDE multimedia module.")
(define-public elisa
(package
(name "elisa")
- (version "0.4.2")
+ (version "20.12.0")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://kde//stable/elisa/0.4.2"
- "/elisa-" version ".tar.xz"))
+ (uri (string-append "mirror://kde/stable/release-service/" version
+ "/src/elisa-" version ".tar.xz"))
(sha256
- (base32 "0v9af6l89pgz1g7naf7gwcnq8znlicyh7z985kxalbdmv359c97w"))))
+ (base32 "02450lsnbd37fms1i2bb9qc9wir4vym6qqd9p5hr6a6s6qwfs6qf"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -188,6 +189,12 @@ This package is part of the KDE multimedia module.")
(system (string-append (assoc-ref inputs "xorg-server")
"/bin/Xvfb :1 -screen 0 640x480x24 &"))
(setenv "DISPLAY" ":1")
+ #t))
+ (replace 'check
+ (lambda* (#:key tests? test-target #:allow-other-keys)
+ (when tests?
+ (setenv "CTEST_OUTPUT_ON_FAILURE" "1")
+ (invoke "dbus-launch" "make" test-target))
#t)))))
(home-page "https://kde.org/applications/multimedia/org.kde.elisa")
(synopsis "Powerful music player for Plasma 5")