summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-multimedia.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2022-07-14 14:21:17 +0200
committerLudovic Courtès <ludo@gnu.org>2022-07-19 18:54:42 +0200
commit3b3fea725017b9f4c6da38d8849a1e16ad8cc353 (patch)
treefc2880df3f05453c2d24ce45a1bb243e7117cb6f /gnu/packages/kde-multimedia.scm
parent95acd67dd3d4f1667b97561099ea66f36ee6485e (diff)
downloadguix-patches-3b3fea725017b9f4c6da38d8849a1e16ad8cc353.tar
guix-patches-3b3fea725017b9f4c6da38d8849a1e16ad8cc353.tar.gz
gnu: k3b: Fix build.
* gnu/packages/kde-multimedia.scm (k3b)[phases]: Add phase fix-cmake-taglib in order to use correct Taglib include and library variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/kde-multimedia.scm')
-rw-r--r--gnu/packages/kde-multimedia.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
index 752f6b499c..bdbf325f15 100644
--- a/gnu/packages/kde-multimedia.scm
+++ b/gnu/packages/kde-multimedia.scm
@@ -373,6 +373,16 @@ variety of formats.")
(("\"(dvdcss)\"" _ library)
(string-append "\"" libdvdcss "/lib/" library "\""))))
#t))
+ (add-before 'configure 'fix-cmake-taglib
+ (lambda _
+ ;; Use the CMake variables provided by FindTaglib from
+ ;; extra-cmake-modules, instead of bundled FindTaglib.cmake:
+ (substitute*
+ '("plugins/decoder/mp3/CMakeLists.txt"
+ "plugins/decoder/flac/CMakeLists.txt"
+ "plugins/project/audiometainforenamer/CMakeLists.txt")
+ (("TAGLIB_INCLUDES") "Taglib_INCLUDE_DIRS")
+ (("TAGLIB_LIBRARIES") "Taglib_LIBRARIES"))))
(add-after 'qt-wrap 'wrap-path
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Set paths to backend programs.