summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-multimedia.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-06 20:47:47 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-26 16:44:53 +0100
commit22b26dd25794532b3c16761d7806ef9ba5c6c8fd (patch)
treed538b026d2dc856098ce32f7e9eb092229424ff1 /gnu/packages/kde-multimedia.scm
parenta8e149434eb1500026256747b4ed21b8bab95926 (diff)
downloadguix-patches-22b26dd25794532b3c16761d7806ef9ba5c6c8fd.tar
guix-patches-22b26dd25794532b3c16761d7806ef9ba5c6c8fd.tar.gz
gnu: Add dragon.
* gnu/packages/kde-multimedia.scm: New file. * gnu/lokal.mk (MODULES): Add it.
Diffstat (limited to 'gnu/packages/kde-multimedia.scm')
-rw-r--r--gnu/packages/kde-multimedia.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnu/packages/kde-multimedia.scm b/gnu/packages/kde-multimedia.scm
new file mode 100644
index 0000000000..7e6d36d204
--- /dev/null
+++ b/gnu/packages/kde-multimedia.scm
@@ -0,0 +1,73 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kde-multimedia)
+ #:use-module (guix build-system qt)
+ #:use-module (guix download)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages qt))
+
+(define-public dragon
+ (package
+ (name "dragon")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/dragon-" version ".tar.xz"))
+ (sha256
+ (base32 "02l16k4sgrxbczxp8rlnxbylb5fmjh4zhl4xw55qxkvmvxnjy5zr"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("kjobwidgets" ,kjobwidgets)
+ ("knotifications" ,knotifications)
+ ("kparts" ,kparts)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("oxygen-icons" ,oxygen-icons) ; default icon set
+ ("phonon" ,phonon)
+ ("phonon-backend-gstreamer" ,phonon-backend-gstreamer)
+ ("qtbase" ,qtbase)
+ ("solid" ,solid)))
+ (home-page "https://kde.org/applications/multimedia/org.kde.dragonplayer")
+ (synopsis "Simple video player")
+ (description "Dragon Player is a multimedia player where the focus is on
+simplicity, instead of features. Dragon Player does one thing, and only one
+thing, which is playing multimedia files. It's simple interface is designed
+not to get in your way and instead empower you to simply play multimedia
+files.
+
+This package is part of the KDE multimedia module.")
+ (license ;; GPL for programs, FDL for documentation
+ (list license:gpl2+ license:fdl1.2+))))