summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-internet.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-09 10:47:25 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:28:11 +0100
commit3588ac9c100bb117634db682f470c2b6faac0b2f (patch)
treec1be895ad9ef19bd0cd9a6517f186d5a464badaa /gnu/packages/kde-internet.scm
parent724bd81d54917878a777e4e6343390bae30b636d (diff)
downloadguix-patches-3588ac9c100bb117634db682f470c2b6faac0b2f.tar
guix-patches-3588ac9c100bb117634db682f470c2b6faac0b2f.tar.gz
gnu: Add ktorrent.
* gnu/packages/kde-internet.scm (ktorrent): New variable.
Diffstat (limited to 'gnu/packages/kde-internet.scm')
-rw-r--r--gnu/packages/kde-internet.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index 9bc91e005a..16eecef258 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -34,6 +34,7 @@
#:use-module (gnu packages libidn)
#:use-module (gnu packages linux)
#:use-module (gnu packages messaging)
+ #:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
@@ -366,6 +367,63 @@ This package is part of the KDE networking module.")
(license ;; GPL for programs, LGPL for libraries, FDL for documentation
(list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
+(define-public ktorrent
+ (package
+ (name "ktorrent")
+ (version "5.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/ktorrent/" version
+ "/ktorrent-" version ".tar.xz"))
+ (sha256
+ (base32 "0kwd0npxfg4mdh7f3xadd2zjlqalpb1jxk61505qpcgcssijf534"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("boost" ,boost)
+ ("gmp" ,gmp)
+ ("karchive" ,karchive)
+ ("kcmutils" ,kcmutils)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdewebkit" ,kdewebkit)
+ ("kdnssd" ,kdnssd)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("kparts" ,kparts)
+ ("kplotting" ,kplotting)
+ ("kross", kross)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("libgcrypt" ,libgcrypt)
+ ("libktorrent" ,libktorrent)
+ ;; TODO: LibKWorkspace -> plasma-workspace?
+ ("oxygen-icons" ,oxygen-icons) ; default icon set
+ ("phonon" ,phonon)
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
+ ("qtwebkit" ,qtwebkit)
+ ("solid" ,solid)
+ ("syndication" ,syndication)
+ ("taglib" ,taglib)))
+ (home-page "https://kde.org/applications/internet/org.kde.ktorrent")
+ (synopsis "BitTorrent client")
+ (description "KTorrent is a BitTorrent application by KDE which allows you
+to download files using the BitTorrent protocol. It enables you to run
+multiple torrents at the same time and comes with extended features to make it
+a full-featured client for BitTorrent.")
+ (license license:gpl2+)))
+
(define-public libktorrent
(package
(name "libktorrent")