summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-23 13:17:30 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:38 +0100
commitfd8c53cb9eaa876d4006a5f0a3096d20d38a064c (patch)
tree7d2b82adbdb4917348905575a18d047394bd0cde /gnu/packages/kde-frameworks.scm
parentb824dbec5d331e79a50734fb543bbe064eb7fc17 (diff)
downloadguix-patches-fd8c53cb9eaa876d4006a5f0a3096d20d38a064c.tar
guix-patches-fd8c53cb9eaa876d4006a5f0a3096d20d38a064c.tar.gz
gnu: kcmutils: Make QDirIterator follow symlinks.
Transfer the NixOS patch "kcmutils-follow-symlinks" for kcmutils as of 2018-02-17. * gnu/packages/kde-frameworks.scm(kcmutils)<patch>: New phase.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index caf846bba9..60f9eeb037 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2016,2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2016,2017,2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -2088,6 +2088,16 @@ using the XBEL format.")
("kservice" ,kservice)))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "src/kpluginselector.cpp"
+ ;; make QDirIterator follow symlinks
+ (("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
+ (string-append a " | QDirIterator::FollowSymlinks" b)))
+ #t)))))
(inputs
`(("kauth" ,kauth)
("kcodecs" ,kcodecs)