summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-23 15:15:23 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:46 +0100
commitfb0356d9564255b6a983960d06d274b3ee3a1903 (patch)
tree9f505dabbb1416a43a10f4436942a4a2f900615f /gnu/packages/kde-frameworks.scm
parent0fd6138175cb6099e2e5f3d112c3188c84b31561 (diff)
downloadguix-patches-fb0356d9564255b6a983960d06d274b3ee3a1903.tar
guix-patches-fb0356d9564255b6a983960d06d274b3ee3a1903.tar.gz
gnu: kservice: Transfer patches from NixOS.
Transfer the NixOS patches for kservice as of 2018-02-17. - Make QDirIterator follow symlinks. - Normalize path, but don't resolve symlinks. * gnu/packages/kde-frameworks.scm(kservice)<patch>: New phase.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 89d52874b8..0d14c8f887 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2979,6 +2979,20 @@ typed.")
`(#:tests? #f ; FIXME: 6/10 tests fail.
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ ;; Adopted from NixOS' patches "qdiriterator-follow-symlinks" and
+ ;; "no-canonicalize-path".
+ (lambda _
+ (substitute* "src/sycoca/kbuildsycoca.cpp"
+ ;; make QDirIterator follow symlinks
+ (("^\\s*(QDirIterator it\\(.*, QDirIterator::Subdirectories)(\\);)" _ a b)
+ (string-append a " | QDirIterator::FollowSymlinks" b)))
+ (substitute* "src/sycoca/vfolder_menu.cpp"
+ ;; Normalize path, but don't resolve symlinks (taken from
+ ;; NixOS)
+ (("^\\s*QString resolved = QDir\\(dir\\)\\.canonicalPath\\(\\);")
+ "QString resolved = QDir::cleanPath(dir);"))
+ #t))
(add-before 'check 'check-setup
(lambda _
(setenv "HOME" (getcwd))