summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-10-29 18:48:28 +0200
committerDavid Craven <david@craven.ch>2016-10-29 23:51:43 +0200
commitc8ddc56e6c53740ccecbb2eecf4d0dab3f6e7fbd (patch)
tree580fb71b8b4f4a4707cc18b36232f752323c9551 /gnu/packages/kde-frameworks.scm
parent2b677becbd32dd7f513b87373225f5176f340dfe (diff)
downloadguix-patches-c8ddc56e6c53740ccecbb2eecf4d0dab3f6e7fbd.tar
guix-patches-c8ddc56e6c53740ccecbb2eecf4d0dab3f6e7fbd.tar.gz
gnu: kiconthemes: Update to 5.27.0.
* gnu/packages/kde-frameworks.scm (kiconthemes): Update to 5.27.0. [arguments]: Return #t.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index a8791c31eb..e77ff33473 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2028,16 +2028,16 @@ window does not need focus for them to be activated.")
(define-public kiconthemes
(package
(name "kiconthemes")
- (version "5.24.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/frameworks/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "1k5zig2n6wzfyv6pc8dpas2862mxjyxxza00m31myrfw5i1a1h6m"))))
+ (version "5.27.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/frameworks/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0m70vcrxp0vvqw5grlsn19d2hgdhky8iv2pr0xwzw8v5yrnl1hh2"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
@@ -2065,7 +2065,8 @@ window does not need focus for them to be activated.")
"/share"))
(setenv "HOME" (getcwd))
(setenv "CTEST_OUTPUT_ON_FAILURE" "1") ; Enable debug output
- (setenv "QT_QPA_PLATFORM" "offscreen"))))))
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ #t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Icon GUI utilities")
(description "This library contains classes to improve the handling of icons