summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-25 21:29:52 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-10-27 20:14:05 +0100
commitb4941e30e3a01a11bf0eac6fd1c68aa33b06aaf8 (patch)
tree2ea156a9dc3e39af0f1b8d0553dfa8343564f753 /gnu/packages/kde-frameworks.scm
parente3908ec5fb96a1fbdc144f5585af49668960dfc8 (diff)
downloadguix-patches-b4941e30e3a01a11bf0eac6fd1c68aa33b06aaf8.tar
guix-patches-b4941e30e3a01a11bf0eac6fd1c68aa33b06aaf8.tar.gz
gnu: kpackage: Fix build errors in dependent packages.
Fix build errors in dependent packages if PREFIX is different from ECM's PREFIX - which is the case in Guix. See <https://bugs.kde.org/424483> for details. * gnu/packages/patches/plasma-framework-fix-KF5PackageMacros.cmake.patch: New file. * gnu/local.mk (dist_patch_DATA) Add it. * packages/kde-frameworks.scm (package)[source]: Use this patch.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index cbcb8ff076..febdb1f4f0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1963,7 +1963,8 @@ covers feedback and persistent events.")
"03rp7p7i8ihz5wg58gjs638jk7xbszknfiy2j3r979snc57g95mv"))
;; Default to: external paths/symlinks can be followed by a
;; package
- (patches (search-patches "kpackage-allow-external-paths.patch"))))
+ (patches (search-patches "kpackage-allow-external-paths.patch"
+ "kpackage-fix-KF5PackageMacros.cmake.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)))