summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-21 17:43:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-05 10:56:37 +0100
commitb1beb1670b91216f8c0fcceff6069da7f922e096 (patch)
tree2451951ebeae95a821e64e656810e5365abc4b21 /gnu/packages/kde-frameworks.scm
parent5bc1efd77dad5dde6bd353a9d29d41d48d83ed55 (diff)
downloadguix-patches-b1beb1670b91216f8c0fcceff6069da7f922e096.tar
guix-patches-b1beb1670b91216f8c0fcceff6069da7f922e096.tar.gz
gnu: krunner: Make some tests pass.
* gnu/packages/kde-frameworks.scm[arguments] <#:tests?>: Remove. <#:phases>[fix-paths-for-test'] New phase. <#:phases>[check-setup]: Set $HOME. Blacklist a failing new-in-5.39.0 test.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 6f261afd1a..78290cf1a9 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2747,13 +2747,26 @@ to easily extend the contacts collection.")
("solid" ,solid)
("threadweaver" ,threadweaver)))
(arguments
- `(#:tests? #f ; FIXME: 1/1 tests fail.
- #:phases
+ `(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths-for-test
+ ;; This test tries to access paths like /home, /usr/bin and /bin/ls
+ ;; which don't exist in the build-container. Change to existing paths.
+ (lambda _
+ (substitute* "autotests/runnercontexttest.cpp"
+ (("/home\"") "/tmp\"") ;; single path-part
+ (("//usr/bin\"") (string-append (getcwd) "\"")) ;; multiple path-parts
+ (("/bin/ls" path)
+ (string-append (assoc-ref %build-inputs "coreutils") path)))))
(add-before 'check 'check-setup
(lambda _
+ (setenv "HOME" (getcwd))
;; make Qt render "offscreen", required for tests
(setenv "QT_QPA_PLATFORM" "offscreen")
+ ;; Blacklist a failing test-function. TODO: Make it pass.
+ (with-output-to-file "bin/BLACKLIST"
+ (lambda _
+ (display "[testMatch]\n*\n")))
#t)))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "Framework for Plasma runners")