summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2021-02-26 16:54:20 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-27 12:28:13 +0100
commit5a402e0302d96bce5f18ff28ed5cac54cbacd29c (patch)
treef25ecdc523c8b147994f96c886febc3020c6a07d /gnu/packages/kde-frameworks.scm
parent72926ce5e5477c160a6ee3282870b1857a47b896 (diff)
downloadguix-patches-5a402e0302d96bce5f18ff28ed5cac54cbacd29c.tar
guix-patches-5a402e0302d96bce5f18ff28ed5cac54cbacd29c.tar.gz
gnu: Add kgraphviewer.
* gnu/packages/kde-frameworks.scm (kgraphviewer): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 5482400f02..ef47a912ad 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -55,6 +56,7 @@
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphics)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages image)
#:use-module (gnu packages kerberos)
@@ -695,6 +697,36 @@ such as printers, to be discovered without any user intervention or centralized
infrastructure.")
(license license:lgpl2.1+)))
+(define-public kgraphviewer
+ (package
+ (name "kgraphviewer")
+ (version "2.4.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/kgraphviewer/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1h6pgg89gvxl8gw7wmkabyqqrzad5pxyv5lsmn1fl4ir8lcc5q2l"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("qtbase" ,qtbase)
+ ("boost" ,boost)
+ ("graphviz" ,graphviz)
+ ("kiconthemes" ,kiconthemes)
+ ("kparts" ,kparts)
+ ("qtsvg" ,qtsvg)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (home-page "https://apps.kde.org/en/kgraphviewer")
+ (synopsis "Graphviz dot graph viewer for KDE")
+ (description "KGraphViewer is a Graphviz DOT graph file viewer, aimed to
+replace the other outdated Graphviz tools.")
+ (license license:gpl2+)))
+
(define-public kguiaddons
(package
(name "kguiaddons")