summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 12:10:33 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 12:13:37 +0100
commit19d8f047c4c57829a2c09ef463ba00b6ceb36bfe (patch)
tree2143125f4d69ec1c1e02cf0a2b7bcd4500d64e08 /gnu/packages/kde-frameworks.scm
parentc6bc0fc3a5b20b1548b550211382acf06308b5dd (diff)
downloadguix-patches-19d8f047c4c57829a2c09ef463ba00b6ceb36bfe.tar
guix-patches-19d8f047c4c57829a2c09ef463ba00b6ceb36bfe.tar.gz
gnu: kcoreaddons: Disable broken test.
* gnu/packages/kde-frameworks.scm (kcoreaddons)[arguments]: Disable benchNotifyWatcher test because it installs too many inotify watches and fails with ENOSPC.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 3865bc1b2e..63c0c9c6ab 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -573,11 +573,14 @@ propagate their changes to their respective configuration files.")
(modify-phases %standard-phases
(add-before 'check 'blacklist-failing-test
(lambda _
- ;; Blacklist a failing test-function. FIXME: Make it pass.
- ;; Test failure caused by stout/stderr being interleaved.
+ ;; Blacklist failing tests.
(with-output-to-file "autotests/BLACKLIST"
(lambda _
- (display "[test_channels]\n*\n")))
+ ;; FIXME: Make it pass. Test failure caused by stout/stderr
+ ;; being interleaved.
+ (display "[test_channels]\n*\n")
+ ;; This fails with ENOSPC because of too many inotify watches.
+ (display "[benchNotifyWatcher]\n*\n")))
#t))
;; See upstream commit ee424e9b62368485bba4193053cabb553a1d268e
(add-after 'unpack 'fix-broken-test