summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-10-19 10:29:10 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-10 22:18:20 +0100
commit15cd7067537b9fdae21e7ca7b9e25da4a6476c14 (patch)
tree5ea670c5433a45e442e7200940538592000f64cf /gnu/packages/kde-frameworks.scm
parent77f144d87ee165490ded1d22082b2b46e77c9c00 (diff)
downloadguix-patches-15cd7067537b9fdae21e7ca7b9e25da4a6476c14.tar
guix-patches-15cd7067537b9fdae21e7ca7b9e25da4a6476c14.tar.gz
gnu: Move kpmcore to kde.scm.
kpmcore is not a framework part. * gnu/packages/kde-frameworks.scm(kpmcore): Move from here … * gnu/packages/kde.scm(kpmcore): … to here.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d4f2ccc903..96aba546aa 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -41,7 +41,6 @@
#:use-module (gnu packages calendar)
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
- #:use-module (gnu packages disk)
#:use-module (gnu packages docbook)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
@@ -214,38 +213,6 @@ Phonon-GStreamer is a backend based on the GStreamer multimedia library.")
;; license: source files mention "either version 2.1 or 3"
(license (list license:lgpl2.1 license:lgpl3))))
-(define-public kpmcore
- (package
- (name "kpmcore")
- (version "3.3.0")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "mirror://kde/stable/kpmcore"
- "/" version "/src/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0s6v0jfrhjg31ri5p6h9n4w29jvasf5dj954j3vfpzl91lygmmmq"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("kconfigwidgets" ,kconfigwidgets)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("ki18n" ,ki18n)
- ("kservice" ,kservice)
- ("libatasmart" ,libatasmart)
- ("parted" ,parted)
- ("qtbase" ,qtbase)
- ("util-linux" ,util-linux)))
- (home-page "https://community.kde.org/Frameworks")
- (synopsis "Library for managing partitions")
- (description "Library for managing partitions.")
- (license license:gpl3+)))
-
;; Tier 1
;;