summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-14 14:09:51 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-24 16:23:21 +0200
commit07e98fb9c42015e3ac618f6e90373e3505ee3ab5 (patch)
tree93593a31fd1e953392130d4683e39adf32e3d0dc /gnu/packages/kde-frameworks.scm
parent3bf9c3afc158464756769d555267f141fdd960a6 (diff)
downloadguix-patches-07e98fb9c42015e3ac618f6e90373e3505ee3ab5.tar
guix-patches-07e98fb9c42015e3ac618f6e90373e3505ee3ab5.tar.gz
gnu: Simplify "Xvbf" invocation in pre-check phases.
* gnu/packages/geo.scm (qgis)[arguments]: Simplify invocation of 'Xvfb' in 'check' phase, assuming 'Xvfb' is in $PATH. * gnu/packages/graphics.scm (opensubdiv)[arguments]: Likewise. * gnu/packages/java-graphics.scm (java-piccolo2d-extras)[arguments]: Likewise. * gnu/packages/kde-frameworks.scm (kcontacts)[arguments]: Likewise. (kdeclarative)[arguments]: Likewise. * gnu/packages/kde-multimedia.scm (elisa)[arguments]: Likewise. * gnu/packages/kde-plasma.scm (kscreenlocker)[arguments]: Likewise. * gnu/packages/radio.scm (gnuradio)[arguments]: Likewise. * gnu/packages/education.scm (gcompris-qt)[arguments]: Likewise. * gnu/packages/freedesktop.scm (weston)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7a3b6b26a8..4fd0817753 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1641,8 +1641,7 @@ integrated it into your application's other widgets.")
;; Xvfb doesn't have proper glx support and needs a pixeldepth
;; of 24 bit to avoid "libGL error: failed to load driver: swrast"
;; "Could not initialize GLX"
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
+ (system "Xvfb :1 -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")
@@ -2386,8 +2385,7 @@ their settings.")
(lambda* (#:key inputs #:allow-other-keys)
;; The test suite requires a running X server, setting
;; QT_QPA_PLATFORM=offscreen does not suffice.
- (system (string-append (assoc-ref inputs "xorg-server")
- "/bin/Xvfb :1 -screen 0 640x480x24 &"))
+ (system "Xvfb :1 -screen 0 640x480x24 &")
(setenv "DISPLAY" ":1")
#t)))))
(home-page "https://community.kde.org/Frameworks")