summaryrefslogtreecommitdiff
path: root/gnu/packages/kawa.scm
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@zancanaro.id.au>2019-06-13 11:14:53 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-13 13:00:37 +0200
commit47f2168b6fabb105565526b2a1243eeeb13008fe (patch)
tree6b0bbffba2bc8d6e2e891cbfb0def077de452acb /gnu/packages/kawa.scm
parent0ddf17dc1ace325e46ba59da850b2a18bca69e33 (diff)
downloadguix-patches-47f2168b6fabb105565526b2a1243eeeb13008fe.tar
guix-patches-47f2168b6fabb105565526b2a1243eeeb13008fe.tar.gz
gnu: Add Kawa.
* gnu/packages/kawa.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/kawa.scm')
-rw-r--r--gnu/packages/kawa.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/kawa.scm b/gnu/packages/kawa.scm
new file mode 100644
index 0000000000..5771eeda8e
--- /dev/null
+++ b/gnu/packages/kawa.scm
@@ -0,0 +1,53 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Carlo Zancanaro <carlo@zancanaro.id.au>
+;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages kawa)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (gnu packages java))
+
+(define-public kawa
+ (package
+ (name "kawa")
+ (version "3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/kawa/kawa-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1k9qpydc64ar4aqyg3q7jmmxy503ayj85227qfhc5n6ngchqavhy"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-build? #f
+ #:parallel-tests? #f))
+ (inputs
+ `(("icedtea" ,icedtea-8 "jdk")))
+ (home-page "https://www.gnu.org/software/kawa/")
+ (synopsis "Java framework and implementation of Scheme, Elisp, and more")
+ (description
+ "GNU Kawa is an implementation of the Scheme programming language that
+is built on top of the Java platform. It is thus conveniently integrated
+with Java and benefits from this by having a compiler, optional static
+typing, and so on. Kawa also serves as a framework for implementing other
+programming languages on the Java platform. Included in Kawa is qexo, a
+partial implementation of XQuery in Java.")
+ (license license:expat)))