summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-06 20:46:15 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-12 12:45:36 -0400
commit3f66c30dbdee18bf5922bdc6c6d86697d1732314 (patch)
tree7900784aa5f8ce8725b44d7030a6f9b4a3bdcee7 /gnu/packages/jupyter.scm
parent5324bff060654c7185c0be1f2ea9e2e2a3b69bd0 (diff)
downloadguix-patches-3f66c30dbdee18bf5922bdc6c6d86697d1732314.tar
guix-patches-3f66c30dbdee18bf5922bdc6c6d86697d1732314.tar.gz
gnu: python-jupyter-packaging: Update to 0.12.0, run test suite.
* gnu/packages/jupyter.scm (python-jupyter-packaging): Update to 0.12.0. [arguments]: New field.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index bea53ba912..d517712bcb 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -21,6 +21,7 @@
(define-module (gnu packages jupyter)
#:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
@@ -215,15 +216,29 @@ the JupyterLab CSS variables.")
(define-public python-jupyter-packaging
(package
(name "python-jupyter-packaging")
- (version "0.9.1")
+ (version "0.12.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "jupyter_packaging" version))
(sha256
(base32
- "0r015c0m713d19asmpimsw6bk2sqv2lpd2nccgjzjdj5h1crg0bg"))))
+ "1b7ssc627vgrdl21c09w9sxk5fc1ps3g7f70laxag4yw1bb5ax5j"))))
(build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Disable isolation so that the package environment can be
+ ;; setup without connectivity.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ (substitute* "tests/test_build_api.py"
+ (("\"-m\", \"build\"" all)
+ (string-append all ", \"--no-isolation\"")))
+ (invoke "python" "-m" "pytest" "-vv")))))))
(propagated-inputs
(list python-deprecation python-packaging python-setuptools
python-tomlkit python-wheel))