summaryrefslogtreecommitdiff
path: root/gnu/packages/jupyter.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-30 18:28:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-30 18:29:57 +0200
commit0d2371d215c81c97b92d697330a561c91c2062c4 (patch)
treed6be03b84cf60af8955aabd09bb2c6fea1c2bebf /gnu/packages/jupyter.scm
parentc9aee89abfb71036ed1e57fe7701dd5aae7c5760 (diff)
downloadguix-patches-0d2371d215c81c97b92d697330a561c91c2062c4.tar
guix-patches-0d2371d215c81c97b92d697330a561c91c2062c4.tar.gz
gnu: Add python-voila.
* gnu/packages/jupyter.scm (python-voila): New variable.
Diffstat (limited to 'gnu/packages/jupyter.scm')
-rw-r--r--gnu/packages/jupyter.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 1900c774db..674bdbbe2b 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -539,3 +539,38 @@ Docker registry.")
sending queries to an SPARQL endpoint and fetching & presenting the results in
a notebook.")
(license license:bsd-3)))
+
+(define-public python-voila
+ (package
+ (name "python-voila")
+ (version "0.2.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "voila" version))
+ (sha256
+ (base32
+ "0krfc95yjlhjdmrsladhy6lpf4xs1zw49nmkyl4pkykndglvwa1m"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-jupyter-client" ,python-jupyter-client)
+ ("python-jupyter-server" ,python-jupyter-server)
+ ("python-nbclient" ,python-nbclient)
+ ("python-nbconvert" ,python-nbconvert)))
+ (native-inputs
+ `(("python-ipywidgets" ,python-ipywidgets)
+ ("python-jupyter-packaging" ,python-jupyter-packaging)
+ ("python-matplotlib" ,python-matplotlib)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-tornasync" ,python-pytest-tornasync)
+ ("python-setuptools" ,python-setuptools)
+ ("python-tornado" ,python-tornado-6)))
+ (home-page "https://github.com/voila-dashboards/voila")
+ (synopsis "Render live Jupyter notebooks with interactive widgets")
+ (description
+ "VoilĂ  turns Jupyter notebooks into standalone web applications. Unlike
+the usual HTML-converted notebooks, each user connecting to the VoilĂ  tornado
+application gets a dedicated Jupyter kernel which can execute the callbacks to
+changes in Jupyter interactive widgets.")
+ (license license:bsd-3)))