summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-02-06 14:14:13 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-06 16:12:50 +0100
commitd40b5684c533e0188ffa213b20f2d3c88406d895 (patch)
treed96d5aa1c1d922cda1b3117a36172573e58cfbde /gnu/packages/julia.scm
parent4e847986bcdbcd7ac18c82b045b942e203332869 (diff)
downloadguix-patches-d40b5684c533e0188ffa213b20f2d3c88406d895.tar
guix-patches-d40b5684c533e0188ffa213b20f2d3c88406d895.tar.gz
gnu: julia: Adjust libgit2 tests.
* gnu/packages/julia.scm (julia)[arguments] <'disable-broken-tests>: Patch libgit2.jl.
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index f6df2817d3..d958995288 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -228,6 +228,12 @@
#t))
(add-before 'check 'disable-broken-tests
(lambda _
+ ;; Adjust expected error messages to match what current libgit2
+ ;; provides.
+ (substitute* "test/libgit2.jl"
+ (("Invalid Content-Type") "invalid Content-Type")
+ (("Failed to resolve path") "failed to resolve path"))
+
(substitute* "test/choosetests.jl"
;; These tests fail, probably because some of the input
;; binaries have been stripped and thus backtraces don't look