summaryrefslogtreecommitdiff
path: root/gnu/packages/julia.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-11-26 00:35:54 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-27 01:22:32 -0500
commit941f776fce7d1edef8a7c8c98022c4187400fc51 (patch)
tree4f410e5af52a0d2886aa80090856b014a0cbeda4 /gnu/packages/julia.scm
parentd508c5baab16f99818e6514351ed0ab7ad9e8116 (diff)
downloadguix-patches-941f776fce7d1edef8a7c8c98022c4187400fc51.tar
guix-patches-941f776fce7d1edef8a7c8c98022c4187400fc51.tar.gz
gnu: julia: Correctly test using '#:parallel-tests?'.
* gnu/packages/julia.scm (julia)[phases]{enable-parallel-tests}: Use PARALLEL-TESTS?, not PARALLEL-BUILD?. Remove comment. * gnu/packages/patches/julia-allow-parallel-build.patch: Move explanatory comment to the top of the patch. Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/julia.scm')
-rw-r--r--gnu/packages/julia.scm7
1 files changed, 2 insertions, 5 deletions
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index ac5bf7db25..83aa8b1099 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -315,11 +315,8 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(substitute* (jlpath "Zlib")
(((from "libz")) (to "zlib" "libz"))))))
(add-after 'unpack 'enable-parallel-tests
- ;; FIXME: julia fails at networking in the container and falls back
- ;; to a single worker, which causes the tests to not run in
- ;; parallel (see: https://github.com/JuliaLang/julia/issues/43205).
- (lambda* (#:key parallel-build? #:allow-other-keys)
- (setenv "JULIA_CPU_THREADS" (if parallel-build?
+ (lambda* (#:key parallel-tests? #:allow-other-keys)
+ (setenv "JULIA_CPU_THREADS" (if parallel-tests?
(number->string (parallel-job-count))
"1"))
(format #t "JULIA_CPU_THREADS environment variable set to ~a~%"