summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 11:30:19 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:20 +0300
commitef15951445a1b34321d7efb6a7e9a97c0fd10adf (patch)
tree9b1c2c0a6a4987d096a2a034961611baf6881aae /gnu/packages/julia-xyz.scm
parent52811a7609af634188cc2cfe4be96feb64c47a3c (diff)
downloadguix-patches-ef15951445a1b34321d7efb6a7e9a97c0fd10adf.tar
guix-patches-ef15951445a1b34321d7efb6a7e9a97c0fd10adf.tar.gz
gnu: Add julia-arrayinterface.
* gnu/packages/julia-xyz.scm (julia-arrayinterface): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e2f5bdb9ec..b574c0125e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -116,6 +116,42 @@ be GPU compatible without throwing away the wrapper.")
provides functions to run a few automatable checks for Julia packages.")
(license license:expat)))
+(define-public julia-arrayinterface
+ (package
+ (name "julia-arrayinterface")
+ (version "3.1.17")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaArrays/ArrayInterface.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1yfl7wsciqm8ggfs6grxdrvpkxniy4c63d05f65v2j0c55z8a6mn"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-ifelse" ,julia-ifelse)
+ ("julia-requires" ,julia-requires)
+ ("julia-static" ,julia-static)))
+ (native-inputs
+ `(("julia-aqua" ,julia-aqua)
+ ("julia-bandedmatrices" ,julia-bandedmatrices)
+ ("julia-blockbandedmatrices" ,julia-blockbandedmatrices)
+ ("julia-ifelse" ,julia-ifelse)
+ ("julia-offsetarrays" ,julia-offsetarrays)
+ ("julia-staticarrays" ,julia-staticarrays)))
+ (home-page "https://github.com/JuliaArrays/ArrayInterface.jl")
+ (synopsis "Base array interface primitives")
+ (description "The purpose of this library is to solidify extensions to the
+current @code{AbstractArray} interface, which are put to use in package
+ecosystems like @code{DifferentialEquations.jl}. Since these libraries are
+live, this package will serve as a staging ground for ideas before they are
+merged into Base Julia. For this reason, no functionality is exported so that
+if such functions are added and exported in a future Base Julia, there will be
+no issues with the upgrade.")
+ (license license:expat)))
+
(define-public julia-arraylayouts
(package
(name "julia-arraylayouts")