summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 10:29:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:48 +0300
commite2496a814f8ac4b62b91e05fc9899b9bb85b3ac4 (patch)
treed080644273a05adea7a2fc74835f1a1c1d539c13 /gnu/packages/julia-xyz.scm
parentf0e0b9a55ac39da37bd0c75d7df6528118eba8cd (diff)
downloadguix-patches-e2496a814f8ac4b62b91e05fc9899b9bb85b3ac4.tar
guix-patches-e2496a814f8ac4b62b91e05fc9899b9bb85b3ac4.tar.gz
gnu: julia-mbedtls-jll: Move to (gnu packages julia-jll).
* gnu/packages/julia-xyz.scm (julia-mbedtls-jll): Move to ... * gnu/packages/julia-jll.scm: ... here.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm43
1 files changed, 1 insertions, 42 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2a49cf5d6a..397e5e597e 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -27,8 +27,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
#:use-module (gnu packages julia-jll)
- #:use-module (gnu packages maths)
- #:use-module (gnu packages tls))
+ #:use-module (gnu packages maths))
(define-public julia-abstractffts
(package
@@ -1147,46 +1146,6 @@ that let you do deep transformations of code.")
TLS} and cryptography C library for Julia.")
(license license:expat)))
-(define-public julia-mbedtls-jll
- (package
- (name "julia-mbedtls-jll")
- ;; version 2.25.0+0 is not compatible with current mbedtls 2.23.0,
- ;; upgrade this when mbedtls is updated in guix
- (version "2.24.0+1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
- (commit (string-append "MbedTLS-v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0kk9dlxdh7yms21npgrdfmjbj8q8ng6kdhrzw3jr2d7rp696kp99"))))
- (build-system julia-build-system)
- (arguments
- '(#:tests? #f ; No runtests.jl
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
- (lambda* (#:key inputs #:allow-other-keys)
- (map
- (lambda (wrapper)
- (substitute* wrapper
- (("generate_wrapper_header.*")
- (string-append
- "generate_wrapper_header(\"MbedTLS\", \""
- (assoc-ref inputs "mbedtls-apache") "\")\n"))))
- ;; There's a Julia file for each platform, override them all
- (find-files "src/wrappers/" "\\.jl$"))
- #t)))))
- (inputs `(("mbedtls-apache" ,mbedtls-apache)))
- (propagated-inputs `(("julia-jllwrappers" ,julia-jllwrappers)))
- (home-page "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
- (synopsis "Apache's mbed TLS binary wrappers")
- (description "This Julia module provides @code{mbed TLS} libraries and
-wrappers.")
- (license license:expat)))
-
(define-public julia-msgpack
(package
(name "julia-msgpack")